Support » Plugin: Gmail SMTP » Curl is available, but GSMTP thinks not.

  • Resolved magdamunro

    (@magdamunro)


    I have WordPress 5.1.1 running under Ubuntu 18.04. curl 7.58.0 is installed by default. Gmail SMTP thinks there is no Curl.

    Server info:

    OS: Linux mywebsite.com 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64
    PHP version: 7.2.15-0ubuntu0.18.04.1
    WordPress version: 5.1.1
    WordPress multisite: No
    openssl: Available
    allow_url_fopen: Enabled
    stream_socket_client: Available
    fsockopen: Available
    cURL: Not Available. In order to make a SMTP connection your server needs to have cURL enabled

    Terminal output:

    user@server: curl --version
    curl 7.58.0 (x86_64-pc-linux-gnu) libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
    Release-Date: 2018-01-24
    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp 
    Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP HTTP2 UnixSockets HTTPS-proxy PSL

    This is before getting connected. Related?

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Curl is available, but GSMTP thinks not.’ is closed to new replies.