Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » cURL error 7: Failed to connect to sitekit.withgoogle.com port 443: Connection

  • Resolved chrisvangelder

    (@chrisvangelder)


    Hi there,

    Enabled Google Site Kit & all was working fine until:

    – Installed WP Cache and smush plugins
    – Redirected DNS through Cloudflar

    Error is: cURL error 7: Failed to connect to sitekit.withgoogle.com port 443: Connection timed out

    What can I do?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Luckyna San

    (@luckynasan)

    Hello @chrisvangelder, thanks for submitting your support topic. If you’d like to share the following information I can see if I notice anything with your current setup:

    1. Do you have any other WordPress sites you can check setup with on the same hosting provider?

    2. If possible, could you temporarily disable software such as firewall or security applications running on your computer or your web hosting provider before setting up Site Kit? (Note that previously users who had similar encounters noticed restrictions from the web application firewall or hosting level.)

    3. Please share your Site Health information, privately via this form if preferred. Please ensure you include your hosting provider in the form.

    Thread Starter chrisvangelder

    (@chrisvangelder)

    Hi there @luckynasan!

    Thanks for your feedback. Site Kit seems to be functioning again and I’m not sure as to why?

    1. Yes – I have checked on another domain and SiteKit is functioning correctly.
    2. SiteKit failed (error as above) – disabled Wordfence firewall – SiteKit works – Reanabled firewall – SiteKit still works!
    3. Done

    Cheers,

    Chris

    Plugin Support Luckyna San

    (@luckynasan)

    @chrisvangelder Thanks for sharing your update! I am glad to hear it is working now.

    If you have a brief moment could you kindly leave a review, please? It would really make my day!

    Feel free to open a new support topic should encounter any issues in the future and we will be happy to help.

    شكرا جزيلا 🌹

    Hi! Don’t know if still useful, but I have the same problem. SOLVED:

    go to your hosting control panel and allow the outgoing connections with Google’s IP. Mine is: 142.250.190.XX

    Hope this help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.