Support » Plugin: WP RSS Aggregator » cURL error 7

  • Resolved yoavxyoav

    (@yoavxyoav)


    Feeds would not import, and I’m suspecting it has to do with an error I get on the WP-Cron events page:

    There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    cURL error 7: Failed to connect to localhost port 8080: Connection refused

    I checked out this page (https://docs.wprssaggregator.com/cron-intervals/), and as it mentions, all my cron jobs seem to be stuck, as they have the (now) near each Next Run schedule.

    How can I solve this?

    Additional info from the debugging page:
    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL: http://localhost:8080/mysite
    HOME_URL: http://localhost:8080/mysite

    Plugin Version: 4.11.1
    WordPress Version: 4.8.2

    Platform: Apple
    Browser Name: Chrome
    Browser Version: 60.0.3112.113
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_11_6) AppleWebKit/537.
    36 (KHTML, like Gecko) Chrome/60
    .0.3112.113 Safari/537.36

    PHP Version: 7.1.7
    MySQL Version: 5.5.5-10.1.25-MariaDB (mysqli)
    Web Server Info: Apache/2.4.26 (Unix) OpenSSL/1.0.2l PHP/7.1.7 mod_perl/2.0.8-dev Perl/v5.16.3

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Post Max Size: 128M
    PHP Time Limit: 30

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 4 Status: Acceptable

    Show On Front: page
    Page On Front: Home #217
    Page For Posts: Home #217

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /opt/lampp/temp/
    Use Cookies: On
    Use Only Cookies: On

    UPLOAD_MAX_FILESIZE: 128MB
    POST_MAX_SIZE: 128MB
    WordPress Memory Limit: 40MB
    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    Nice Quotes Rotator: 1.0
    WP-RTL: 1.0
    WP Crontrol: 1.5
    WP RSS Aggregator: 4.11.1

    DEACTIVATED PLUGINS:

    Akismet Anti-Spam: 3.3.3
    One Click Demo Import: 2.3.0

    CURRENT THEME:

    Mambo: 1.2

    ### End System Info ###

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @yoavxyoav,

    For stuck cron issue, we have two pages in our documentation that suggest ways of handling this problem. We have some tips on this page that generally solve the problem, and another workaround is available on this page.

    Since it seems that you are running this on your localhost, you might want to check your localhost setup and please make sure that your WP-Cron is running. Depends on what localhost setup you are using, you can check its related documentation regarding how to run WP-Cron properly.

    Hope this helps.

    yoavxyoav

    (@yoavxyoav)

    @erricgunawan

    Hi Eric, thanks for your reply. I have tried the documentation, at least the part that does not require setup a separate Cron server, so far no success.

    I should have mentioned that my site is set up in a XAMPP virtual machine, so it’s actually not on localhost but being forwarded thorugh port 8080 to the machine’s localhost. Have you ever came across problems with such a setup?

    Thanks

    Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @yoavxyoav,

    Unfortunately, we don’t have any experiences with such a setup.

    Please try to look for in XAMPP forum or such on how to run or set up a cron properly with how the way you set your local development.

    Alternatively, you can try another local development setup such as the one listed here:
    https://www.codeinwp.com/blog/local-wordpress-development-tools/

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.