Support » Fixing WordPress » cURL error 60 when updating WordPress

  • I have had an issue for a number of months now that have not had teh time to look at, but today I tried to investigate why I keep getting a cURL issue when trying to update WordPress or any associated Themes.
    I have even gone so far as to download WordPress.org certs and add them to my cert store.

    When doing an update via the browser you get a cURL 60: Peers Certificate is not recognized error.

    When I open a terminal window (Centos 7) and try and curl the URL i.e http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip
    There is an Error message returned from the WordPress Server, running NGINX,, Error 301 Moved Permanently.

    However if you cURL the same adress but instead use HTTPS then the file can be successfully accessed https://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip

    Using Wget will also work.

    Is this something that the WordPress Admins can fix ? Perhaps a setting in NGINX not to return the 301 and redirect to HTTPS or update such that all URL’s for updates are automatically HTTPS rather than http needing to be redirected ??

    Will save a lot of time and allow the Auto Update tools available through WordPress and others to operate effectively.

    It does seem to be more of an issue from what I can tell when the server is behind a Proxy Server but looks like it is something that could get resolved by WordPress developers

    I have seen lots of topics complaining about this issue and I will admit I am not expert or why it would be necessary to start the update session using HTTP when the server is set to redirect to HTTPS..

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • When I open a terminal window (Centos 7) and try and curl the URL i.e http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip
    There is an Error message returned from the WordPress Server, running NGINX,, Error 301 Moved Permanently.

    What happens when you use the flag “–location” for curl via command line?

    Is your server up-to-date? (you may run yum update to update all packages in the server).

    Sorry for the delay.
    Yes, my server is up to date. I use WebMin to keep the server current without issues. I have experienced the same issue on a Windows Server as well. Both Servers are behind a Network Proxy Server. If I cURL HTTP from Linux, I get a 301 Moved Permanently error, but if I use HTTPS instead which is what WordPress update is forcing (for good reason) then the file is downloaded.

    If I use curl http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip -location
    I get
    %Total %Received %Xfer Average_Dload Speed_Upload Time_Total Time_Spent Time_Left Current_Speed

    100 162 100 162 0 0 1209 0 –:–:– –:–:– –:–:– 1218

    That’s bit strange. No further idea on why the error occurs (“cURL 60: Peers Certificate is not recognized error”).

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.