• Resolved dan1952iel


    I just installed Newsletter.
    I just finished my first newsletter. The test works fine and I could send the newletter to the test account. I receive the newsletter well.
    By cons sends to my subscribers is not done. I have the following message:

    cURL error 35: error:1408F10B:SSL routines:ssl3_get_record:wrong version number

    Here is the information about my environment:

    Ubuntu 18.04
    WP : 5.1
    Apache PHP 7.3.2-3+ubuntu18.04.1+deb.sury.org+1
    Mysql : 5.7.25
    Curl : php7.3-curl
    Local postfix server using PHP interface with WP

    All is up to date

    Could you please support me.
    Many thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter dan1952iel


    Here is additional information:
    root@mail:/# curl -V

    curl 7.58.0 (x86_64-pc-linux-gnu) libcurl/7.58.0 OpenSSL/1.1.1b zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
    Release-Date: 2018-01-24
    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp
    Features: AsynchDNS IDN IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz TLS-SRP HTTP2 UnixSockets HTTPS-proxy PSL


    root@mail:/# openssl version

    OpenSSL 1.1.1b 26 Feb 2019

    Sems to be the right level.
    Could you please support me.
    Many thanks

    Thread Starter dan1952iel


    I just found the mistake. This is an error due to the change from php 7.2 to php 7.3. The system update failed to update some settings.
    By passing the command “php -v” I saw that the system was version 7.2 although WordPress uses version 7.3.
    This is quite disturbing because I thought to be completely 7.3 whereas some parts of the system still use 7.2.
    Here are the commands to enter at the console.
    sudo a2dismod php7.2
    sudo service apache2 restart
    sudo a2enmod php7.3
    sudo update-alternatives –set php /usr/bin/php7.3
    sudo service apache2 restart
    So we force php to the correct version throughout the system.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘cURL error 35’ is closed to new replies.