Support » Localhost Installs » cURL error 28 – the saga continues

  • Ok, well. I’m running the latest WordPress on an Apache server with PHP. Naturally. Running on OSX 10.15.5, and yes, I have the Mac apache turned off.

    Ok,
    This is the error that I”m sure you are all familiar with.

    Your server is blocking external requests to exactmetrics.com, please check your firewall settings or contact your host for more details. Error message: cURL error 28: Resolving timed out after 2001 milliseconds

    Now, I’ve followed the advice of just about everyone on the internet to fix this to no avail. What is a nuisance is that I can’t see q way to monitor what is making the call to the cURl in the first place.
    However:
    Using Wireshark I can see that exactmetrics.com is reachable, and is responding. I am getting stats from exactmetrics.com on the dashboard.

    I can also go to Terminal and do a direct call to exactmetrics using cURL, as in;

    curl https://exactmetrics.com -I and it responds
    robert$ curl http://exactmetrics.com -I
    HTTP/1.1 301 Moved Permanently
    Server: nginx/1.19.0
    Date: Thu, 02 Jul 2020 12:40:08 GMT
    Content-Type: text/html; charset=UTF-8
    Set-Cookie: edd_wp_session=6177cacf4e95ce3fdbadef479dc2b707%7C%7C1593736808%7C%7C1593735008; expires=Fri, 03-Jul-2020 00:40:08 GMT; Max-Age=43200; path=/
    X-Frame-Options: SAMEORIGIN

    So I’m left scratching my head. Everything is talking to exactmetrics except the Site HEalth part of WordPress.

    This error has been getting reported for years. It’s about time it was solved really? Or at least someone found a working solution.

    Robert

    • This topic was modified 1 year, 3 months ago by James Huff. Reason: moved to Localhost Installs since this is a localhost install

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘cURL error 28 – the saga continues’ is closed to new replies.