Support » Plugin: Forms: 3rd-Party Integration » cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes receive

  • We are using 3rd Party Integration with GravityForms. Most of the time it works fine, but we occasionally get an error “cURL error 28” (raw response below). I searched the forum for this error but did not find anything and made inquries to GF and our Server Support Team.

    • GravityForms basically said “Not It!”.
    • Our server team wanted to know if this plugin processes anything on another server? If so our fire wall might be causing an issue with it?
    • Is this a server, GF or 3rdParty Integration issue?
    • What other avenues can I explore to resolve this?

    **RAW RESPONSE**
    Array
    (
    [safe_message] => error object
    [object] => WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes received
    )

    )

    [error_data] => Array
    (
    )

    )

    )

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter Jacob Medley

    (@jacobmedley)

    @zaus

    Any idea about this?

    I recently got this error as well. I believe it actually has to do with the third party service (CRM?) that you’re trying to post data to.

    This plugin looks for a request from whatever endpoint you give it in the settings. If it can’t reach that endpoint before the timeout period, it will return that error to you.

    I have this error many time.

    I work with contact form 7 and Pardot to send many contact forms values.

    The values are transmitted but i have this error…

    I have no solution for the moment !

    joshuabaer23

    (@joshuabaer23)

    Any word on this @jacobmedley ? Same situation with me. Can you provide any tips which may have helped you get to the bottom of this issue?

    pgsvensk

    (@pgsvensk)

    @joshuabaer23 and @jacobmedley … I am seeing this exact error as well when attempting to post action to a 3rd party CRM. A straight HTML form works, but not a CF7 or GF form using this plug-in. Any ideas? Thanks!

    joshuabaer23

    (@joshuabaer23)

    @pgsvensk Im working at this still. I too have my form pushing to a crm, but I use Zapier to do so. Zapier explained I am having a time out error with curl and to contact my host. My host shrugged their shoulders and I am continuing my search. I submitted with gravity today. Ill update once I know more.

    wp4me

    (@edikitt)

    @joshuabaer23 @pgsvensk

    As stated above, this is an issue with the endpoint that the plugin is trying to reach. For both of you, it sounds like this is your CRM.

    If you’re getting this error every time, you’re likely using the wrong endpoint (Submission URL field in the plugin settings). I’d suggest reaching out to your CRM and asking them what the appropriate cURL would be to use with a 3rd party API.

    If it only happens occasionally, the endpoint timeout might be set too low. This is set by the 3rd party CRM or service you’re trying to connect to (not the plugin), so you don’t have a whole lot of control in this regard. It could realistically be caused by a number of things, but most likely just a brief spike in yours or your CRM’s server load at the time of the submission that caused it to hit the set timeout limit. You can ask your CRM if they can increase the timeout limit, but if it’s only an occasional occurrence, it’s probably less of a hassle to just manually re-submit these submissions as they come in.

    If it happens quite often, but not all the time, you probably have an issue with your server load. Consider reaching out to your host to increase your memory or see if there are any long-running processes on your server that are eating it up.

    • This reply was modified 4 years ago by wp4me.

    I have found that this issue can be from a few different things. The logs were important to help in identifying which direction to go. In my case, curl wasnt ever pushing out of my server. It never reached an endpont to be rejected or retarded.

    In my case, my hosts security platform was governing the heavy curl output on my server, hence why some worked, while some did not. Getting your host to fix this issue was another story. Another server simply solved me.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes receive’ is closed to new replies.