Support » Plugin: Wordfence Security - Firewall & Malware Scan » cURL error 28: Operation timed out

  • Resolved alduinwf

    (@alduinwf)


    Hello,

    my server load told me that my site is under attack 😉
    So I went ahead and gave it the Wordfence treatment. However, the diagnostics tell me that cURL fails.

    I did auto-update WordPress, and I did install Wordfence using the install plugins UI. So there is not a connection problem per se.

    I also googled. Google said, I can verify a working connection by running this:

    telnet noc1.wordfence.com 443
    telnet noc1.wordfence.com 80

    In both cases, it connects just fine and when I “quit”, I get a Bad Request HTML response which is to be expected.

    The issue is displayed in the Connectivity tab under “Connecting back to this site”:
    wp_remote_post() test back to this server failed! Response was: cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    cURL is working. On the server, and apparently also in PHP (because I did upgrade it with that one-click-mechanism)

    root@dragonserver:/etc/network/interfaces.d# curl https://noc1.wordfence.com 
    {"errorMsg":"Wordfence API error: Your site did not send an API key when contacting the Wordfence servers."}
    root@dragonserver:/etc/network/interfaces.d# 

    I’m running a pretty vanilla Debian 9.8. PHP is provided by FPM running on top of Apache with FastCGI.

    What can I do to fix this? 🙂

    Thank you!

    Alduin

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @alduinwf,

    can you go into Wordfence -> Tools -> Diagnostics -> Debugging Options and enable Start all scans remotely?

    For example: https://i.imgur.com/Sv4kUbv.png

    I saw that the warning you received was wp_remote_post() test back to this server failed!, so I suspect this is caused by your server unable to connect to its own hostname.

    Dave

    Hi,

    thanks for your reply. I enabled this option on one of the sites on that server.

    What do you mean with “server is unable to connect to its own hostname”? When I do a

    host dragonserver.alduin.we

    or a

    host my-domain-with-wordfence.tld

    on ssh, it correctly returns its own IP, in both cases. I double-checked this because it’s some sort of cloud server (you know, where you get a virtual machine on a host server or whatever) so it’s got some weird internal IP that nobody uses and a public IP, in both cases, it resolves to the public IP (the one entered in the DNS zone file)…

    Alduin

    OK, um, I was able to sort this. Problem was that php-fpm was set to have 1 child and the request worker was busy with the request and no worker was able to to actually get this callback test. Increased number of php-fpm children and works now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.