Support » Localhost Installs » Curl error 28 after moving computer to new location

  • andrewatmcd

    (@andrewatmcd)


    Hello all,

    I’m in the middle of building a site, and doing so with a Windows Subsystem for Linux install as a server on my workstation. My wp_options table lists a http://site.local domain for siteurl and home, and naturally my workstation’s host file points that to 127.0.0.1.

    My employer got shutdown due to the coronavirus, and I carried my workstation home with me. Now, however, I’m getting this curl error and the site can’t contact wordpress.org to browse plugins (or themes or update or etc). Naturally my IP changed, but I can’t see anywhere where WordPress might have been saving the old one.

    What’s the deal here? I’ve disabled all the plugins and switched to a stock theme, just to make sure that none of those items were the problem.

    Sitehealth info check output:

    
    

    ### wp-core ###

    version: 5.3.2
    site_language: en_US
    user_language: en_US
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: cURL error 28: Resolving timed out after 10518 milliseconds

    ### wp-paths-sizes ###

    wordpress_path: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public
    wordpress_size: 396.15 MB (415395744 bytes)
    uploads_path: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content/uploads
    uploads_size: 306.00 MB (320862350 bytes)
    themes_path: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content/themes
    themes_size: 13.43 MB (14086797 bytes)
    plugins_path: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content/plugins
    plugins_size: 99.68 MB (104523516 bytes)
    database_size: 19.90 MB (20867617 bytes)
    total_size: 835.17 MB (875736024 bytes)

    ### wp-active-theme ###

    name: Twenty Twenty (twentytwenty)
    version: 1.1
    author: the WordPress team
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, woocommerce, post-thumbnails, automatic-feed-links, custom-background, custom-logo, title-tag, html5, align-wide, customize-selective-refresh-widgets, editor-color-palette, editor-font-sizes, menus, widgets, editor-style
    theme_path: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content/themes/twentytwenty

    ### wp-themes-inactive (6) ###

    Neto Child: version: 1.0.0, author: Andrew B
    Neto: version: 1.8, author: CSSIgniter
    Storefront: version: 2.5.3, author: Automattic (latest version: 2.5.5)
    Twenty Nineteen: version: 1.4, author: the WordPress team
    Twenty Seventeen: version: 2.2, author: the WordPress team
    Twenty Sixteen: version: 2.0, author: the WordPress team

    ### wp-plugins-active (13) ###

    Caldera Forms: version: 1.8.11, author: Caldera Labs
    Classic Editor: version: 1.5, author: WordPress Contributors
    Elementor: version: 2.9.6, author: Elementor.com
    Health Check & Troubleshooting: version: 1.4.3, author: The WordPress.org community
    Media Library Folders for WordPress: version: 5.1.9, author: Max Foundry
    QuadMenu: version: 2.0.2, author: Mega Menu
    SiteOrigin CSS: version: 1.2.5, author: SiteOrigin
    WooCommerce: version: 3.9.1, author: Automattic
    WooCommerce Admin: version: 0.24.0, author: WooCommerce
    WooCommerce TM Extra Product Options: version: 4.9.7, author: themeComplete
    WOOF – WooCommerce Products Filter: version: 1.2.3, author: realmag777
    WP Featherlight: version: 1.3.0, author: Cipher
    WP Retina 2x: version: 5.6.0, author: Jordy Meow

    ### wp-plugins-inactive (2) ###

    Media Library Folders for WordPress Reset: version: 5.1.9, author: Max Foundry
    WooCommerce Services: version: 1.22.3, author: Automattic

    ### wp-media ###

    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: 2.2.5
    ghostscript_version: not available

    ### wp-server ###

    server_architecture: Linux 4.4.0-18362-Microsoft x86_64
    httpd_software: Apache/2.4.29 (Ubuntu)
    php_version: 7.2.24-0ubuntu0.18.04.1 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 20M
    php_post_max_size: 8M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: false
    server-headers:
    date: Thu, 02 Apr 2020 15:22:05 GMT
    server: Apache/2.4.29 (Ubuntu)
    expires: Wed, 11 Jan 1984 05:00:00 GMT
    cache-control: no-transform, no-cache, no-store, must-revalidate
    link: <http://redacted.local/wp-json/&gt;; rel=”https://api.w.org/&#8221;
    vary: Accept-Encoding
    content-encoding: gzip
    content-length: 14996
    content-type: text/html; charset=UTF-8
    htaccess_extra_rules: false

    ### wp-database ###

    extension: mysqli
    server_version: 5.7.28-0ubuntu0.18.04.4
    client_version: mysqlnd 5.0.12-dev – 20150407 – $Id: 3591daad22de08524295e1bd073aceeff11e6579 $

    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content
    WP_PLUGIN_DIR: /mnt/c/Users/Andrew/Desktop/wsl-projects/redacted/public/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    `

Viewing 5 replies - 1 through 5 (of 5 total)
  • Can you ping wordpress.org from within WSL?

    It might be worth changing your DNS to something like 1.1.1.1 or 8.8.8.8 and see if there’s a difference.

    andrewatmcd

    (@andrewatmcd)

    Ah, interesting. I cannot. I changed the DNS in Windows, which I would think would also take effect in WSL, but I’m not positive on that. Good thinking!

    I don’t really have any experience with WSL, but I’d think that linux would cache network information until a disconnect/reconnect.
    I’d just restart the machine if I were you 🙂

    andrewatmcd

    (@andrewatmcd)

    So this was totally a WSL issue. It turns out that I couldn’t even do an apt-get since it couldn’t connect out. Restarting didn’t seem to do anything.

    The fix for me, taken from the discussion in a bug report (https://github.com/microsoft/WSL/issues/4285), was to simply remove /etc/resolv.conf (in Ubuntu terminal: “sudo rm /etc/resolve.conf”) then shutdown the ubuntu server (in cmd: “wsl -t Ubuntu”). For good measure I restarted the workstation.

    It regenerates the resolv.conf file on startup and we’re off to the races.

    Thanks for the help!

    Glad you could sort it out!

    Hope you’re enjoying our Neto theme 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.