Support » Plugin: Customer Reviews for WooCommerce » cURL and REST API / server host issue

  • Resolved sugavida

    (@sugavida)


    I cannot display reviews received and apparently this is due to cURL and REST API being disabled.

    My server host will not enable due to ‘security reasons’, stating I need a web developer or another type of server

    Any advice?!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support ivole2

    (@ivole2)

    @sugavida thank you for using our plugin.

    If your server host will not enable it for you that is something we have no control of. What I can tell you is that the new WordPress REST API code is vetted by many security professionals, like the core code of WordPress is. WordPress core itself had its fair share of vulnerabilities but they were always addressed on time. So as long as you keep your WordPress up to date you should not have any issues.

    Thank you for your response.

    My WordPress is up to date and I have received my test review (do you think therefore the diagnostics page is displaying incorrectly?)

    However how do I then set this up to display on the relevant product page of my website?

    Thank you

    Plugin Support ivole2

    (@ivole2)

    @sugavida did you submit that review through cusrev aggregated review form?

    Please follow the instruction on this article on how to show the reviews on your product pages.

    https://cusrev.freshdesk.com/support/solutions/articles/43000033867-reviews-not-showing-on-product-page

    Yes I did, I think!

    When I go to edit individual product pages , the ‘Enable reviews’ checkbox does not appear on the advanced tab

    Would you know why that may be?

    thank you

    Plugin Support ivole2

    (@ivole2)

    It is most likely disabled by your WordPress theme. I would suggest for you to contact your theme developer to verify and ask how to turn it on.

    The Enable Reviews check shows up correctly on my admin side.

    Plugin Support ivole2

    (@ivole2)

    @dsdewitt. I’m not sure what you mean by that. Are you experiencing the same issue as @sugavida?

    I was just confirming that it works correctly for me.

    Plugin Support ivole2

    (@ivole2)

    @dsdewitt thank you for that =). This is why I strongly believe that something on sugavida’s wordpress installation is causing it. Most likely his theme.

    Hi iVole2

    Re your message: It is most likely disabled by your WordPress theme. I would suggest for you to contact your theme developer to verify and ask how to turn it on.

    I contacted my developer and he said the theme wouldn’t affect wordpress features? But is this more to do with the product pages display? Are you able to suggest something more accurate to ask him re the theme? thanks a lot

    Plugin Support ivole2

    (@ivole2)

    My WordPress is up to date and I have received my test review (do you think therefore the diagnostics page is displaying incorrectly?)

    @sugavida can you please send me the product page URL where you left that test review so that I can check it on my end? Also please send me a screenshot of the “Reviews” page from your admin dashboard showing that review that you left.

    How can I send you the screen shot please? Here is the associated product page : https://sugavida.co.uk/product/sugavida-palmyra-nectar-natures-original-100-pure-plant-energy/

    Plugin Support ivole2

    (@ivole2)

    @sugavida you can upload the image to your media library and place the image URL here so that I can check it.

    sugavida

    (@sugavida)

    Plugin Support ivole2

    (@ivole2)

    @sugavida I have checked your site and I found that your product page has “write a review” link on top which allows visitors to send reviews via email. See screenshot below.

    2019-05-16_1330

    So your developer must have disabled the default Woocommerce review function to prevent visitors from using it and force them to use that “write a review” link on top. Please contact your developer to verify this.

    • This reply was modified 2 months ago by  ivole2.
Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.