Support » Fixing WordPress » CTRL+Z and Link button made me lose over 600 words

  • Whenever I try to add a link, I have to do it 5 times before it actually works. This time it was the worst.

    I was typing a sentence and then went to re-read it to look for the right words to add a link to. Once I found the words, the add a link button failed (once again) and instead added the URL of the page I was trying to link to the top of the page.

    I then pressed ctrl+z to undo the URL added at the top of the page, but this instead redid the last 7-8 paragraphs I wrote. This was roughly 600 words in length and at least 30 minutes of constant brainstorming and writing.

    PLEASE fix the add a link and undo button.

    EDIT: There is no redo button, for some reason.

    • This topic was modified 10 months, 3 weeks ago by andyvnguyen.
Viewing 16 replies (of 16 total)
  • While you are correct, @otto42, this does indeed appear to be a bug and the Classic Editor block is something that cannot be dismissed.

    @andyvnguyen, if you believe your issue matches the one described on, please add the details of your experience with this issue to that bug report and the steps you take to reproduce it.

    In your report, note that you are using the Classic Editor block.

    It is also likely that the undo issue you experienced was due to the Classic Editor block and I will investigate this a bit more tomorrow. Feel free to search GitHub, Trac, and the forums for any similar issues and to see if there’s an open bug report.

    As for using Gutenberg, if you have content in a Classic Block, you can try converting it to individual blocks by clicking the Convert to Blocks option. Here’s a screenshot of that:

    As @otto42 noted, setting links to open in new tabs works properly there.

    • This reply was modified 10 months, 3 weeks ago by verygoode.
Viewing 16 replies (of 16 total)
  • The topic ‘CTRL+Z and Link button made me lose over 600 words’ is closed to new replies.