Support » Plugin: Business Directory Plugin » CSV Not Importing

  • Resolved kingfirley

    (@kingfirley)


    I am having a problem importing my CSV file. Every time I import it I get this message: Import was completed successfully
    Import Summary
    Correctly imported rows:
    0
    Rejected rows:
    0

    And nothing gets imported.

    Here is a sample of my CSV:

    business-name,city-location,state-location,business-website-address,business-phone-number,business-genre
    Composites Canada,Mississauga,ON,www.compositescanada.com,(877) 773-7336,Preferred Distributors
    Composites One,Arlington,WA,www.compositesone.com,(800) 283-0809,Preferred Distributors
    Composites One,Langley,BC,www.compositesone.com,(800) 663-0449,Preferred Distributors
    Composites One,Vancouver,WA,www.compositesone.com,(800) 255-6006,Preferred Distributors
    Composites One,Salt Lake City,UT,www.compositesone.com,(800) 444-0156,Preferred Distributors

    http://wordpress.org/extend/plugins/business-directory-plugin/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    Hi kingfirley,

    What version of BD are you running?
    Are you importing on a Windows or Linux web host?
    Do you know if your database is in strict mode or not?
    Have you added any extra fields to your form, or are the ones above all you have?
    What happens if you try to import the sample CSV file generated by BD at the bottom of the CSV Import page?

    Hi!
    I am running version Version 2.1.6.1
    Server is running Linux
    I don’t know about the database
    As far as the fields I took the original excel file changed the names of the fields to be correct with the ones for the directory plugin and I added the business genre one
    When I import the sample it seems to work correctly

    Thanks!

    One thing to add and I don’t know if it makes a difference, I have these fields set up on my directory:

    business-name,business-contact-name,business-genre,city-location,state-location,short-business-description,long-business-description,business-website-address,business-phone-number,business-contact-email

    But on the csv I am trying to import, it only uses:
    business-name,business-genre,city-location,state-location,business-website-address,business-phone-number

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    Aha. That’s the problem.

    So the CSV file must have ALL columns represented. You can’t just pick and choose which ones to include.

    You can leave the columns blank for the fields you’re not using, but you must have all of them present. That’s why the sample works and yours does not.

    Ok, I understand but it’s still not working correctly. Here is a link to a screen shot of all the form fields I have on my form and the csv file I am using. Can you please look at it and see if it is set up correctly? I really think I am doing this correctly.

    https://dl.dropbox.com/u/33225963/directory.zip

    Thanks!

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    OK, your field setup states that long and short descriptions are required fields, but you are not including any data for import in the CSV for those two fields (in fact, all fields are required except for Phone Number and Contact Name). While the import probably ought to call that out, have you tried either making those fields optional OR putting some test data in to see if it works?

    Ok so I made the fields optional but now I get this:

    https://dl.dropbox.com/u/33225963/Screen.png

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    So that error is telling you that rows 3 and 4 are a problem. What does their data look like compared to the other first two rows? Have you modified the file since you posted it?

    Does the import work if you delete those two rows?

    No I havent modified it. When I delete rows 3 and 4 I get the same message. Can you please look at my files and let me know they are set up correct?
    https://dl.dropbox.com/u/33225963/directory.zip

    Never mind. I found out the problem. I’m an idiot lol. Thank you som much for your help!

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    You’re welcome.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘CSV Not Importing’ is closed to new replies.