Support » Plugins and Hacks » .csv not displaying properly

.csv not displaying properly

  • When sending the completed email to the admin, I have the option to send the .csv checked. However the .csv only contains a date.

    If I view the submissions and download the .csv it displays fine. (Although it could be better formatted. If there’s a way to do this please let me know.)

    Using v 2.2.3.



Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author James Laws


    Thanks foe the heads up. We’ll try and reproduce and report back.

    As far as formatting I’m not sure what you mean. It’s a comma separated list which are devoid of formatting. If you would like to clarify we’d be happy to hear any suggestions.

    Thanks for the fast reply. I can see that you guys have excellent support.

    As for the formatting it was simple a request from a client. No worries on that one as I assumed it’s out of the plugin’s control.

    Again, many thanks!

    Plugin Author James Laws


    You are very welcome. As soon as we track the CSV issue down we will report back. Thanks for using Ninja Forms. 🙂

    Plugin Author Kevin Stover


    I’ve done some testing with version 2.2.3, and I can’t recreate the issue you’re experiencing. Could you shoot me an email with an export of the form you’re using? my email is kevin@wpninjas.com.

    Will do, thanks.

    Plugin Author Kevin Stover


    Just tested out your form on our server, and I get the CSV file populated with all the field data in my email. What version of Ninja Forms are you using?

    Thanks for testing that.

    I’m using version 2.2.3. Also using the Layout & Styles addon if that matters.

    Tried it on a different form on the site as well and I just get a .csv with the date in the first field only. I’ll try reinstalling the plugin. Unless you have other suggestions? Could this be a server issue? permissions? Current setup is in a subdomain on a testing environment.

    Plugin Author Kevin Stover


    I’m not sure what’s going on there. There shouldn’t be any server settings that would cause that. If you export an individual CSV file, does it download correctly?

    Yeah if I go to submissions and download it it’s perfect.

    Let me disable other plugins and try some other stuff. If you have any other suggestions throw them my way. Thanks for your help!

    No luck with disabling other plugins. If I do figure out what the deal was in my situation I’ll share it here to hopefully help others in the future. Having the .csv on submit isn’t a deal breaker for this one so I’m okay with that. I’ll be reinstalling WP and all plugins when this site goes live so maybe that will help.

    Love the plugin and your support is great!

    Plugin Author Kevin Stover


    Thanks. I’m sorry that isn’t working for you. I honestly don’t know what would change on the server to make CSV output not work. The same function is called when you download a CSV file directly, so I don’t have many ideas. :\

    If you do find something out, please let me know!

    Update: New install of WordPress, fresh database, new install of plugin, imported my form and still just a .csv file with only the date. Even tried it on a new form. So the only things that remained the same are the server.

    Question, could this have anything to do with my php.ini file? I edited it to make it work for my longer form as stated on your forums. Used this:

    ; increasing max input for ninja forms
    max_input_vars = 10000

    No clue why I can’t get this going. Will try a new server soon.

    Further information: Tested on a different server. New WP setup, new plugin install, new form. Nothing from the old server/site. Same issue.

    I get the same .csv file that only contains one field with the date in it.

    The only common link is it’s the same hosting company which is Media Temple. https://www.mediatemple.net/


    I tested this on a non MT hosting account and it works fine. I’m really unsure why the hosting company would matter, or if that’s even the issue, but it works.

    So while I hope this isn’t an issue that others come across. It is an issue that I can’t figure out why it’s not working. So to reiterate:

    Server 1 (MT Hosting): .csv contained in email with date only
    Server 2 (MT hosting, fresh blank WP and plugin install): same issue
    Server 3 (non MT hosting, existing blog been up for years): works fine.

    Hopefully this feedback will help you guys determine the issue?

    Plugin Author James Laws


    I wonder if you could reach out to mediatemple and explain the issue if they could offer some insight from their server perspective. Although I agree, I can’t think of why the server would cause this issue right off.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘.csv not displaying properly’ is closed to new replies.