Support » Plugin: Business Directory Plugin » CSV Imports 2 entries at a time

  • Resolved nycexs

    (@nycexs)


    Using WordPress 4.0, BD Version 3.4. Tried to upload a CSV file of 238 entries (some with photos some without) and could only upload 2 at a time. Broke it down to 50 with photos, still no luck, the upload rate remains 2.

    Did an upload of the entries w/out photos and it worked fine, mind you, that was only 10 entries.

    Any help would be greatly appreciated.

    https://wordpress.org/plugins/business-directory-plugin/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    Hi nycexs,

    Sorry that you ran into issues here.

    Can you upgrade to BD 3.5.2 and try it again? That version of BD is old enough now that we’ve likely fixed a number of import issues and one of them might be what you’re seeing.

    Try that and report back. We’ll take it from there.

    Latest install, & a total of one upload…Hmm.

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    OK. Something else must be going on here. Can you tell me:
    – What settings you’re using for import? (A screenshot is best, use http://imageshack.us if you need to)
    – Are you on shared hosting?
    – Have you tried a conflict test? Here is an article about how to test for theme and plugin conflicts with Business Directory, which may help pinpoint the issue: http://businessdirectoryplugin.com/support-forum/faq/how-to-check-for-plugin-and-theme-conflicts-with-bd/
    – Is the CSV file you’re using really large?
    – Are you including images? If so, what is the average size of them?

    Report back on those as they can affect the import too.

    Settings: https://nimbus.everhelper.me/client/notes/share/109758/qz1GdMCP1xKaRnpTlF84CayAbZ2NeC7h/

    Hosting: Shared

    Ok, “just the bones” test>> Fatal error: Maximum execution time of 5 seconds exceeded in /home/domainname/public_html/wp-includes/class-wp-image-editor.php on line 405

    The CSV file is 228 entries with 218 photos, each photo is between 14kb -24kb the images zip file is 6.5 mb.

    I’ve tried to do a CSV file upload w/photos of just 50 and the result was one upload.

    I then excluded photos from the full CSV file and that uploaded fine.

    Here’s a kicker, as I was just about to start adding the images, it turns out that the image to each entry was imported. For some reason the entries uploaded and published w/out the photos. Whew! That’s another mystery, for another day.

    Thank you for your help.

    Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    So part of the mystery is actually in the error message you posted above:

    “Fatal error: Maximum execution time of 5 seconds exceeded in /home/domainname/public_html/wp-includes/class-wp-image-editor.php on line 405 “

    That would come from a setting on your web hosting server. 5 seconds is way to short for any meaningful uploads to be allowed. 30 seconds is average, longer than that is better for slow servers. Shared hosting will often limit resources in ways to avoid over-consuming what the server has, but this too causes problems for things where you need some processing power. You have to have a certain level of horsepower to pull in ads with images on import. Sounds like your server is vastly underpowered for that (a 5 second timeout is a strong indicator of that). There’s not much that BD can do in light of that.

    You may try uploading the images to the ads manually and see if you have better luck, but with an underpowered server, I don’t know there’s much else I can suggest. Here’s an article on why shared hosting is a long-term problem for most sites: http://businessdirectoryplugin.com/support-forum/faq/what-kind-of-hosting-should-i-use-for-wordpress-and-why-is-shared-hosting-a-problem/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘CSV Imports 2 entries at a time’ is closed to new replies.