Support » Plugin: TablePress » CSV import bug

  • Resolved dromanov31

    (@dromanov31)


    Hello!

    When importing from csv file the plugin imports several rows (each time different amount). The trouble is that it imports not all rows but part of them. So I can’t import whole table at once.

    Thanks in advance!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    Can you make this CSV file available somewhere, e.g. upload it somewhere? And where (which program) does the CSV file come from?

    Regards,
    Tobias

    There are four examples of CSV files in this archive: https://drive.google.com/open?id=1jNi5ah6wlvyfijyEo-4cXyBF8cVAna4u

    CSV come from Google Docs (Tables).

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    ok, and how are you importing these? Are you uploading single CSV files, or the ZIP archive? Or are you using the URL import source? And are all four files not working properly?

    Regards,
    Tobias

    Hello!

    I’m importing single CSV files by file upload.

    All four are importing with bugs (not all rows imported).

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    I now tried directly importing all four tables (by directly importing the ZIP file), and they are all imported fine.
    What happens if you directly upload/import the ZIP file?

    Regards,
    Tobias

    Hello, Tobias

    Directly importing ZIP file causes the same bug. Tables imported are not complete.
    Maybe there are conflicts or configuration errors on my site?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    yes, that’s likely then. The server needs full PHP ZIP and UTF-8 support.

    Can you maybe export the wrongly imported tables to a ZIP archive and upload that somewhere? That way, I can directly compare the tables maybe.

    Regards,
    Tobias

    I’ve exported these bad tables and got corrupted ZIP archive, which could not be opened with Windows standard ZIP utility.

    I opened ZIP with 7-Zip open source software, and tables inside the archive are not complete again.

    Here is the link to the exported archive: https://drive.google.com/open?id=1L8MPSRiQZ1k7Kv9kP4FaxxH1di-Jff3S

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    ok, that’s strange. I can therefore only assume that something with the character encoding configuration is not working probably on your server 🙁 Unfortunately, I don’t really know how I can help with this, because I’m not an expert with this. You should check if everything is configured for UTF-8 on the server.

    Regards,
    Tobias

    Thanks a lot Tobias!

    I’ll try to check server settings. For me it is a strange bug too.

    Thanks for your patience and happy New year!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    if you find something that I can do, please let me know!

    Best wishes and a Happy New Year, too,
    Tobias

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.