Support » Plugin: Redirection » .csv file upload not working after updates

Viewing 14 replies - 31 through 44 (of 44 total)
  • Looks like we can safely say…that this plugin is no longer supported by the creator. Not answering issues any more it seems. Sad…this was an awesome plugin.

    Thank you Rob W but I am still getting the same error, “No items were imported” at the top of the options page after I click on Upload. Like I said in the previous comment, I don’t think it is uploading at all. BTW, I also tried to upload a .htaccess version but still same message. :S

    Question:
    If I were to uninstall this plugin and reinstall a different version of it (2.4.1 or 2.4.0 for example), will it delete all the redirects? I ask because I do not want to uninstall and reinstall and then find out that I can’t upload anything at all. I would be completely SOL since we have over 300 redirects and it would be a very tedious process to re-enter them manually.

    Can you upload anything to your media library? It could be your server

    @stephdotnet you mod rocks! Thanks for helping : )

    Rob W: I did test by uploading to the media library and it does upload with no issues……I am so lost as to why it does not work on my side. I also tested with different browsers (I mention this in case I forgot to mention earlier) and does not work, I get same error.

    At this point, we are going to have to bite the bullet and enter any new redirects manually. I got a hunch though that the error is something in the code of the plugin files (in my case, in the Upload functions or similar). I rather spent hours entering the redirects manually than reviewing code that isn’t mine. Thanks for your help in any case Rob W and everyone else!

    Can we start a Kickstarter or something, I’d be happy to pay for this to be fixed. I’d even be grateful for any kind of information, if there will ever be another update or if I should look into another solution. Such a shame, it’s a really neat plugin.

    Plugin Author John Godley

    (@johnny5)

    People people… I understand your frustration when something doesn’t work, but if I go away for a few weeks it doesn’t mean the plugin is abandoned. I have been supporting the plugin for over 7 years and will continue to do so, but please understand this is not my full-time job, I don’t get paid for it, and there are far too many forums threads that contain the word ‘redirection’ (whether about this plugin or not) for me to check.

    The fix from Stephdotnet, while making the importer work, does break other things.

    The issue was fixed in 2.4.2 on Github, but I didn’t copy everything across to SVN. I have released 2.4.3 which includes the fixed importer.

    @john thank you so much! You’re awesome

    @anyone that can answer:

    Newbie question, when updating the plugin will it delete the stored redirects already in place? Or can I just update and that’s it?

    JBREC_IT, no stored redirects will be removed on updates.

    Thank you for all that you do John!

    Feedback for John:

    Could you add the info on CSV file structure that Rob W kindly spelled out at https://wordpress.org/support/topic/csv-file-upload-not-working-after-updates/page/2?replies=42#post-7545193 into the plugin’s homepage at http://urbangiraffe.com/plugins/redirection/ ?

    And in turn, link to the plugin’s homepage from the plugin page at WordPress.org here, or from the FAQ tab. It took me a trip to github before I land on the plugin’s homepage, and an incidental find on this support thread to figure out the CSV columns and data format.

    Thanks!

    I just came across this thread and was to having this issue of the import not working.

    I am using Version 2.4.5

    After much fiddling, Stephdotnet’s solution didn’t work (the line number is now 170) for me, what did work was setting up groups, once I split my 176 redirects into 3 groups – a single csv file for each one – and then imported each and imported each into one of three groups it worked.

    • This reply was modified 2 years, 11 months ago by  cucocreative.
    • This reply was modified 2 years, 11 months ago by  cucocreative.

    I would also echo what @cucocreative said. If you don’t have any groups, your import will SAY it worked, but it will not have put anything anywhere. This is perhaps something the developer needs to address, as it’s confusing when starting out. So define at least 1 group and when you import you can specify that you’re importing into that group. Note, if the group is, for example, Apache, you’ll also need to define where your .htaccess file is so that in addition to updating the database, the plugin can update the .htaccess file.

Viewing 14 replies - 31 through 44 (of 44 total)
  • The topic ‘.csv file upload not working after updates’ is closed to new replies.