Support » Plugin: HD Quiz » CSV Bulk Importer not working

  • I am trying to upload a csv containing over 250 questions. I modelled my file after example csv given in the plugin. But somehow, I am not able to load full set of questions. It loads only 150 or so questions. Again even the ones which are imported are not 100% correct. Sometimes a question is repeated, other times a few questions skipped.

    I also created a smaller subset of 10 questions of which only first 2 questions getting uploaded every time. I tried putting quotes around all fields, removing quotes, nothing works. It doesn’t give any error either during upload.

    This is frustrating. Did anybody had this issue?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Harmonic Design

    (@harmonic_design)

    Hi aussian,
    just a friendly warning that as is stated multiple times on the import tool, the amount/level of support that can be offered for this tool is limited. This is because any issues are almost certainly related to either your server or an improperly formatted CSV.

    With that said, here are some helpful tips.

    Use the Bulk Modify Questions button located on the main HD Quiz page to quickly delete and clear out questions, allowing you to rerun the bulk importer fresh and avoid duplicates.

    Make sure your CSV is properly formatted. “even the ones which are imported are not 100% correct” tells me that this is an issue you have. CSV us great because it’s a nice simple and open format. The downside is that it is a very fragile format and easy to break if you’re not careful. For example, since , commas are used as field delimeters, if one of your question or answers contains a comma – your CSV will be broken. Feel free to post a link to your example 10 question file so I can take a look.

    Patience is a virtue and depending on your server or hosting account, you may just have to wait. Some host accountns set an artificial limit on how many times wp-ajax can be accessed, some hosts are just super slow, and some hosts are “shared” hosts – so another account/website on the same server may be using up all of the resources and you have to wait in line. In any of these cases, just wait.

    During the import, you will get one of three results after each batch of questions or quizzes has been added. “added x / y questions”, “all questions have been added”, or “there was a server error adding one of your quizzes”.

    If you are still waiting one of these messages to happen, then just wait – any of the above issues could be happening.

    Hi Harmonic design,

    Thanks for your prompt reply. I understand that there can be limitations or restrictions from hosting provider. That’s why I decided to run it on my local setup. Since my 10 questions were not working, I decided to use the sample csv you have provided and unsurprisingly, it too didn’t load beyond two questions. Please note that I didn’t change the sample csv in any way.

    In any case, here is the link to my set of questions: Smallset.csv

    Let me know if you see any formatting issue in the file.
    Thanks again for all the help!

    Plugin Author Harmonic Design

    (@harmonic_design)

    I downloaded your CSV and uploaded it without issue on my live dev server and on a local install.

    note: the link was to the direct text of the CSV, so I copy/pasted it into a new file. This might be relevant if you were saving the file with incorrect encoding, but since it happens with my example CSV as well, I don’t think that is the problem.

    VIDEO: https://gofile.io/d/shI7kW

    This means that whatever your issue is, it’s likely related to something specific about your install. Perhaps a modified version of WordPress, or something about your theme or another plugin has an error that is stopping the import tool from sending the data.

    The only idea I have to help diagnose this is to use your browser’s console to check for errors. On most browsers, this can be opened up by pressing F12.

    With the console open, try to use the import tool again and see if there are any errors or messages that appear there. With a bit of luck, it will point us in the correct direction.

    Thanks for looking into it. I will try your suggestion and check for errors in the console. I will let you know if I find anything.

    Hi Harmonic Design

    I have the same issue exactly as mentioned by @aussian

    It used to work before. But not anymore. Loading only the first row. I have tried .csv, UTF-8 CSV, with double quotes, without double quotes etc.,

    I get the following message on screen ‘Adding questions has begun. Please do not leave this page until complete.’ But nothing happens.

    I also tried to upload from different browsers. In both Chrome and Firefox, I see 1 user message and 1 error in the console (given below).

    Uncaught ReferenceError: HDQ is not defined
    <anonymous> https://xxxxx.com/wp-admin/?page=hdq_tools_csv_importer:328
    setTimeout handler* https://xxxxx.com/wp-admin/?page=hdq_tools_csv_importer:328
    wp-admin:328:23

    HDQ: Importer loaded hdq_csv_import.js:12:11

    Any clue would help. Thank you.

    • This reply was modified 2 months, 1 week ago by litumahi.

    By the way @aussian , did you manage to upload. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.