Support » Plugin: WooCommerce » CSV bulk import error

  • Resolved abbyw1

    (@abbyw1)


    I tried to import a file of around 6000 external products to WooCommerce and have had various issues with it.

    Firstly, it is taking so long to import, but that isn’t my main problem. All my products upload to the backend perfectly – I can see every field and product and they are all correct. But when I go to the front end and view them in my store, I can’t see anything at all. All the product archive pages are there but no products.

    (I also tried using Featured Image From URL plugin so that I wasn’t uploading so much image data to my website, and this worked on the backend but I still had the problem).

    I checked my dashboard and found this error message:

    WP_Error Object ( [errors] => Array ( [woocommerce_product_importer_invalid_type] => Array ( [0] => Invalid product type. ) ) [error_data] => Array ( [woocommerce_product_importer_invalid_type] => Array ( [row] => ) ) )

    I don’t know what this means, but I’m unsure how there’s an error with the products being invalid when I can see them perfectly fine in the backend.

    I have also previously imported the same file with less rows in (approx 10-50 rows) just to check that my fields are correct, and these imports have worked fine on both backend and frontend.

    I have tried deactivating all my plugins and changed theme to Twenty Nineteen to see if there were any conflicts with either two but the problem still persisted.

    Please let me know if there are any solutions.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Rynald0s

    (@rynald0s)

    Automattic Happiness Engineer

    Hi @abbyw1!

    It sounds like the product/s you’re importing isn’t one of the core WooCommerce product types. What are you using to do your bulk CSV imports — the built-in product importer or another plugin?

    Additionally, you mention that these are external products. Where are they exported from?

    Cheers!

    Hi @rynald0s

    Thanks for your help.

    I’m using the built in CSV importer and instead of simple products it’s an external product and then the button goes to an external URL. It’s in the WooCommerce product type drop down so I don’t see why it shouldn’t work.

    They just link to products I have manually told it to link to in the CSV file – I’ve taken the details from various websites and just put it in a spreadsheet, they’re not exported from anywhere in particular.

    It’s strange though because it works for me when I upload in small batches. It seems to be the large imports that throw it off.

    Thanks!

    Plugin Support m155y5

    (@m155y5)

    Automattic Happiness Engineer

    @abbyw1

    It could be that the import doesn’t like the data in the CSV file you’re importing from. I would suggest that you create one of these external products manually, export the CSV file, and ensure that the new products you’re adding to the CSV are formatted the same way.

    Additionally, server errors while attempting to import can be caused by your server configuration. That might explain why the smaller batches are working.

    Common sources of server configuration problems include:
    Maximum Upload File Size (PHP): This is set in php.ini with upload_max_filesize. It determines the maximum file size that your server will allow to be uploaded. This value must be larger than the size of the file you wish to import.

    Maximum Post Size (PHP): This is set in php.ini with post_max_size. It determines the maximum file size allowed to be used in the PHP process. This should be set higher than upload_max_filesize.

    Memory Limit (PHP): This is set in php.ini with memory_limit. It determines how much memory a script is able to allocate. This should be set higher than post_max_size.

    Plugin Support m155y5

    (@m155y5)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to go ahead and mark this thread as resolved. If you have any other questions please feel free to start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.