Support » Fixing WordPress » CSS&JS Minify: The eternal problem!

  • Hi to all,

    I’m sorry about the “theatrical” title, but sometimes I fell like as if I was in a sort of limbo regarding this problem.

    For more than a month I’m trying to minimize and combine js and css files of my site without success.

    I’ve tried lots of combining/caching plugins (W3 Total Cache, WP Super Cache, JS & CSS Script Optimizer, WP Minify). I can not summarize all my attempts here because it would be excessive and since I have not figured out yet where the problem is, I think it could be also unuseful.

    The problem is always the same: “Internal Server Error”
    All the time I activated the plugin mentioned above I’ve returned this kind of error following the link of the new combinend css/js file.

    I was careful about permissions on ftp
    Of course, following the instruction provided by the plugin authors, I’ve always set the right permissions (777) on my ‘cache’ folder on the ftp.

    I’ve tried to edit the .htaccess file
    The problem led me to think that there might be some limit on my ftp, so I’ve tried removing some lines (one at a time) from the various .htaccess files created by the plugins.

    Can anyone help me to identify the problem?
    I’m ready to do all the efforts needed. If you need other data or if you want me to try something, just ask. I’ve started some discussion on the plugin’s support forum but after some weeks I still have not received a reply.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Andrew Nevins


    Forum moderator

    Could you link to an example of the problem and let us know which plugin is causing it?

    As I said, I’ve tried different plugins.

    For example BWP Minify. Here is the related discussion:

    Here is the not working link:
    Click here

    Moderator Andrew Nevins


    Forum moderator

    Where did you get that not working link from?

    From my website (, after activating the BWP Minify (same result with W3 Total Cache, JS&CSS Optimizer, etc)

    <link rel='stylesheet' type='text/css' media='all' href=',wp-content/plugins/revslider/rs-plugin/css/settings.css,wp-content/plugins/revslider/rs-plugin/css/captions.css,wp-content/themes/fawola2/_fawola/bootstrap/css/bootstrap.min.css,wp-content/themes/fawola2/_fawola/bootstrap/css/bootstrap-responsive.min.css,wp-content/themes/fawola2/style.css,wp-content/themes/fawola2/_fawola/jlp/jlp.css,wp-content/themes/fawola2/_fawola/backtotop/backtotop.css,wp-content/themes/fawola2/style-elements.css,wp-content/themes/fawola2/style-types.css,wp-content/themes/fawola2/style-mobile.css,wp-content/themes/fawola2/_fawola/shortcodes/colorbox/colorbox.css,wp-content/themes/fawola2/_fawola/shortcodes/highlight/sunburst.css,wp-content/themes/fawola2/_fawola/shortcodes/shortcodes.css,wp-content/plugins/social-sharing-toolkit/style_2.1.2.css' />

    PS: I can’t leave my website without any style, so the plugin is actually disabled.

    Moderator Andrew Nevins


    Forum moderator

    Does the issue persist on the Twenty Twelve/Thirteen theme with all other plugins deactivated?


    Here are some screenshots:

    Twenty Twelve activated
    My plugins, all disabled but BWPMinify
    BWP Minify setting page (only css minifying activated)
    My website (still no style)

    The CSS file that gets the Internal Server Error problem:
    <link rel='stylesheet' type='text/css' media='all' href='' />


    The server log output me these errors:

    Premature end of script headers: index.php, referer:
    suexec policy violation: see suexec log for more details, referer:

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘CSS&JS Minify: The eternal problem!’ is closed to new replies.