CSS won't load under OmniSecure v3.0a2 (6 posts)

  1. jerm
    Posted 10 years ago #

    I've had this problem forever and never got a solution so I thought I'd ask you guys!
    My CSS doesn't work (load) when I'm testing my WordPress site with Firefox under Omnisecure v3.0a2 - WinXP. If I take off the DTD it would work but then when I upload the page something would go wrong because DTD/No-DTD = different outcome?
    Anyone has the same problem? It WOULD work if I dump the CSS in the header but that's just messy!

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    What options to load the css have you tried ? Could it be the import rule ?
    Have you tried just using a standard call, as you could then revert to the import after upload.
    <link rel="stylesheet" type="text/css" href="wp-layout.css" />

  3. jerm
    Posted 10 years ago #

    Yeap tried that as well and it wouldn't work. The only thing that works is when I dump my CSS in the <head> area inside <style>. BTW this is a problem with Firefox only, IE works just fine but who cares about IE these days?

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    IE - true :)
    I don't think the DTD will make any difference to the css as it is used to id the (x)html language, so maybe for now dumping it all into the head may have to be the way ?
    I've not come across this Omnisecure before, and I don't recall a post here previously about it. Do they have a product forum ?

  5. jerm
    Posted 10 years ago #

    Now that I think about it it might not be OmniSecure at all [and their site is at http://omnicron.ca btw]. I think it's a Firefox issue, since loading plain HTML files with embedded CSS also seem to not work. Gahh this is frustrating!! I hate dumping CSS in my header!!

  6. skegnet1
    Posted 8 years ago #

    This problem appears to be server side and prevents css style sheets bing correctly parsed by Mozilla based browsers.

    Try This:

    In your programe files open the Omnisecure folder.

    Load file: oadmin.exe

    Click: Web Server Global Settings
    Click: "MIME" Tab.
    In Vertual Input: text/css
    In Actual Inpiu: ".css" - don't foprget the dot.
    Click: Add
    Click OK.

    Good re-boot required.

    On my system this resolved the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.