Support » Fixing WordPress » CSS weird bug

  • Hi,

    recently I had a problem with my Shop page (link above). The page suddenly has majority of empty area but it works sometimes (then another bug activates after Shop problem dissapears…).

    Anyway, I have been trying to solve it for last 5 days without any progress. My (SiteGround) host told me this after a lot of tickets:

    “Adem Sherifov
    Support GuruPosts: 4427Posted On 7 Oct, 2017 12:53 CDT
    Thank you for getting back Josip,

    I have checked the backend and the shop page in particular but could not see anything that would explain the white page issue. I have tried changing the php version of the application but to no avail.

    However, I discovered that the issue is caused by the second application inside the public_html/sailboatrc.com folder. That was also the reason why you had a redirect inside the .htaccess to that subfolder. Please note that all missing css files are at the following directory:

    Code:
    /home/josipm22/public_html/sailboatrc.com/wp-content/uploads/fusion-scripts

    While they need to be at /home/josipm22/public_html/wp-content/uploads/fusion-scripts.

    What you can do in order to resolve the issue is copy the css files from the previous location to /home/josipm22/public_html/wp-content/uploads/fusion-scripts. This is quite a custom setup, so we would advise you to consult with a professional developer with extensive knowledge in WordPress and also maybe in the fusion plugin you have used, in order to properly configure the website.

    Best Regards,

    Adem Sherifov
    Technical Support Team”

    [redacted]

    Anybody, help, please?! I have more “curious data and history of this weird bug which suddenly appeared because my Shop page was forking several days without any problem, if you need I can c/p my conversations with my host support…

    With regards,

    Josip M.

    • This topic was modified 2 years, 1 month ago by  Steve Stern. Reason: fixed up formatting, removed contact stuff

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I’m am 100% sure you mean well but please never offer credentials on these forums.

    https://make.wordpress.org/support/handbook/forum-welcome/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    Well, you are right, but I thought there are some official WordPress help members who are visiting this forum…
    Ok, then what can I share, this inspect?
    http://prntscr.com/gujd75
    ERROR says failed to load resources :S
    My programmer left me so I am in a great struggle to fix this…

    Here is another weird thing, I created a backup because I needed my shop to work, and its fine now, but my homepage is messed up like this now: http://prntscr.com/gujvu0
    So, anytime when someone types in exactly this: http://www.sailboatrc.com (without https), my page is loaded with “double link” as shown in SS.

    This problem was solved by my host support, but then they mess up my Shop which is more important to me…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Well, you are right, but I thought there are some official WordPress help members who are visiting this forum

    No matter who stops by these forums, the important thing to remember is that they are publicly accessible, everyone can see this topic, and that means that all the major search engines can cache it too.

    If you shared something like a password before Steve removed it, please do change that password immediately.

    As for your site, it does seem to be working properly for me: http://d.pr/i/MqnsWH/4FwPiEdq

    If it isn’t for you, try clearing your browser’s cache: http://www.refreshyourcache.com/

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    It looks OK to me, too.

    Yeah, the site works fine now because I did a backup, BUT now there is my ‘old bug’ back – if you type in manually in URL http://www.sailboatrc.com you will actually load on: https://sailboatrc.com/sailboatrc.com/
    Check it out here: http://prntscr.com/guqrbp
    So, all the newcomers who typle http://www.sailboatrc.com (without https) will get messed up landing page.

    If I fix this bug by editing .htaccess file as recommended by my host provider, then my Shop page stops working…
    Such a weird thing really, I am killing myself for 6 days in a row now with no results.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Please show your .htaccess. There’s probably a 301 redirect for SSL that’s incorrect.

    Well, I have two, this one is from ‘higher tier map, /public_html/.htaccess:

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^sailboatrc.com$ [NC,OR]
    RewriteCond %{HTTP_HOST} ^www.sailboatrc.com$
    RewriteCond %{REQUEST_URI} !sailboatrc.com/
    RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    RewriteRule (.*) /sailboatrc.com/$1 [L]

    and this one is from subfolder, public_html/public_html/sailboatrc.com:

    # HTTPS forced by SG-Optimizer
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END HTTPS
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    BUT, this was already solved with my Customer Support member who resolved it this way:

    “Thank you for getting back Josip,

    I have removed the redirection entries inside your .htaccess and replaced them with the default WordPress rewrite rules:

    Code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    After doing that, the redirect to the non-existing folder is gone, and you can verify this by clearing your browser’s cache. You can also check this online tool for the results:

    https://geopeeker.com/fetch/?url=WWW.SAILBOATRC.COM

    And the reason why the shop page is not showing properly is because a file is missing from your website:

    https://sailboatrc.com/wp-content/uploads/fusion-scripts/b48236d78e83938db8ba69ec655fce7d.js

    This file is opened when accessing the shop page but since the files does not exist, the shop is not loading properly. If the website was previously working, we would advise you to run a backup restore for a specific date within 30 calendar days back. Please note that it is not recommended for two applications to share a single database as the changes in one of the websites can break the functionality of the other one.

    If there is anything else we can help you with, please open a new ticket.”

    AFTER we did that, the “Double link problem” was gone, but my Shop page was messed up with some bug, and then we are back to my first post up above in which I have explained that already…

    • This reply was modified 2 years, 1 month ago by  Steve Stern. Reason: put code in backticks
    • This reply was modified 2 years, 1 month ago by  Steve Stern.
    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Using the default WP .htaccess file, reset your permalinks. go to settings->permalinks and click “save”. See if that fixes the “shop” problem.

    I tried, no help. The same problems remain so I did a backup again to have functional Shop at least. Either the Shop works and I have “double link as homepage” problem, or the home page loads correct only http://www.sailboatrc.com but then my Shop is totally messed up with some bug. (missing .css file from fusion elements…)

    The one solution could be this which is too advanced for me:

    “What you can do in order to resolve the issue is copy the css files from the previous location to /home/josipm22/public_html/wp-content/uploads/fusion-scripts.”

    🙁

    I tried to avoid my lack of programming skills and while the Shop was working on my site, I turned on a redirect option from ||www.sailboatrc.com|| to ||https://sailboatrc.com|| but then my Shop page got this:

    “404 – Not Found
    The page you are trying to access does not exist.
    If this error persists, please contact the website webmaster.
    If you are the webmaster of this site make sure that:

    You have uploaded correctly your files to the public_html directory which is the web-root of your account;
    You have not misspelled the URL. Bear in mind that letters are case sensitive and no white spaces are recommended;
    In case you have applied SEO – SEF URL rewriting rules, make sure you have re-named the htaccess.txt file to .htaccess. If there is already a non-empty .htaccess file read it and make sure the necessary rules are un-commented.”

    So even that quick fix wasn’t able to help me out…

    • This reply was modified 2 years, 1 month ago by  josipwp.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What do you have set as your Site and WordPress addresses at Settings > General in your site’s Dashboard?

    Also, what do you have your permalinks set as at Settings > Permalinks in your site’s Dashboard?

    Both addresses are set like this: https://sailboatrc.com

    Permalinks (under Settings) are:

    Common Settings
    Post name: https://sailboatrc.com/sample-post/

    Optional
    Avada portfolio category base: portfolio_category
    Avada portfolio skill base: portfolio_skills
    Avada portfolio tag base: portfolio_tags
    Product category base: product-category
    Product tag base: product-tag

    Product permalinks
    Default: https://sailboatrc.com/product/sample-product/

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, that’s fine.

    Next, edit each .htaccess file and rename it to just htaccess (remove the dot).

    If that solves the main problem (this will cause other problems, so only focus on the main problem), add the dot back to each htaccess file until you find the one causing the problem.

    josipwp

    (@josipwp)

    Dear James,

    So, I have tried to erase my double site from cPanel (somehow I have double site copied, have no idea who did that…), and I did delete it successfully. So, I deleted first my sailboatrc.com folder and then I saw how that messed up my site (Shop not working), so I used backup, and in next turn I deleted the second copied site and saw how that messed up my site (404 error). Once I edited .htaccess file to default WordPress code, and once I copied the plugins folder which had that one file missing (or was corrupted) – that was messing up my shop page, I had http://www.sailboatrc.com link working excellent and with it my Shop page was working great. I was so happy, finally, I copied healthy plugins folder instead of the corrupted one, and I have deleted double site inside my host data, and my www. link was working great! That lasted for about a day, and then again somehow my Shop got messed up, and I only remember that I updated some plugins in the meanwhile. So I am back to square one again, I used backup again…
    Does that mean that I will run on old plugins now? If it does, wouldn’t that slow my page down in future and even cause security issues in future? 🙁

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘CSS weird bug’ is closed to new replies.