Google Language Translator
[resolved] CSS to sit flags on same row as dropdown? (8 posts)

  1. bradadams
    Posted 1 year ago #


    I've currently got 3 translation flags above the dropdown, I've had a look through the support threads but couldn't find anything for this.

    I'd like to sit the flags on the left or right side of the dropdown menu, is there already some CSS provided for this?

    Thanks! :)


  2. Rob Myrick
    Plugin Author

    Posted 1 year ago #

    Hi bradadams, thanks for your post, and sorry for such a long delay in my response to you.

    No, there is not CSS provided for this as of now - although I'm sure another user somewhere out there has already done this.

    Would you like me to help? Send your website link here, and I will try to help without logging into your site, although honestly it would be much faster if you just let me fix it.


    Thanks for using the plugin, Rob

  3. bradadams
    Posted 1 year ago #

    Hey Rob,

    Thanks for the reply, I've contacted you via the link supplied.


  4. Rob Myrick
    Plugin Author

    Posted 1 year ago #

    Hi Brad, let's start with this - just let me know what you need afterwards:

    #google_language_translator {
    #flags {

    Thanks for using the plugin!

  5. bradadams
    Posted 1 year ago #

    Woah, that was fast!!

    Thanks Rob, I think I've finally understood what clear does! :)

  6. Rob Myrick
    Plugin Author

    Posted 1 year ago #

    Good job man! Let me know if you need adjustments - thanks!

  7. bradadams
    Posted 10 months ago #

    Hey again Rob!

    Any chance you could take a look at the site again? I think it's due to an update to the plug-in or something, but the language flags are appearing vertically again :-/

    Screenshot: http://goo.gl/BfQNdA

    Site: http://goo.gl/kSx5VF


  8. Rob Myrick
    Plugin Author

    Posted 10 months ago #

    Hi bradadams,

    Try this CSS by adding it to "Settings > Google Language Translator" in the CSS overrides box:

    .goo_trans #flags {
        width:100px !important;
    .widget ul li {
        clear:none !important;

    It seems that your theme has some styles over-riding the plugin styles :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Language Translator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.