Support » Theme: Twenty Seventeen » CSS to remove whitespace on left???

  • So frustrated! I had my site working the way I want at one point by using posts instead of pages for all my pages.

    All I want is for each page (including my home page) to be one single column, with the huge whitespace on the left gone!!! And, I don’t want that huge home page image on any page. Can this be done with CSS or the settings? I had it at one point and did somthing and lsot it.

    If you go to my site now and click on any page link (including the Home link) in the menu, the resulting ‘page’ (they are really all posts) look just as I want. But if you go to the root of my site directly (click link below), I get that huge dang image again and a ton of whitespace on the left. Here is my site:

    http://www.daledietrich.com

    Help!!!!!!

    • This topic was modified 2 years, 11 months ago by Dale Dietrich.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Dale, in regards to the large header images you don’t want on your pages, you can take care of this by going to your WordPress Dashboard:

    Appearance -> Customize -> Header Media

    Under the Header Media section, there will be two options:

    – Hide Image
    – Add New Image

    Here, you can click Hide Image and that will erase the header images from your site.

    As for the front page of your site (the root, if you will), it seems that it is set to display posts. For this, I recommend you change these settings by going to your WordPress Dashboard again:

    Settings -> Reading

    The first section you see here will be “Front page displays”. Here, you should first check that you have set your front page display to Static Page.

    Then set your static page setting to your Welcome Page (the page I’m assuming you would like visitors to see first when they arrive at your site) or to any page you like.

    Then be sure to assign your Posts page setting to “Blog” or any other page you like. Note, you will have had to have created these pages beforehand in order of them to show in the options.

    And that should take care of your homepage setting.

    Lastly, for your site to be single column, you can change it to this setting by going to:

    Appearance -> Customize -> Theme Options

    Under the Page Layout section, be sure to check “One Column”.

    Hope this helps.

    • This reply was modified 2 years, 11 months ago by pauloeaquino.

    I believe he wanted the Posts page to be the Home page, and the 2 coulmn setting (or at least the margin) removed. I’m also having this issue.

    Is there a snippet within index.php that could be edited to achieve this?

    Finally, with the Home page image, and subsequent Featured Images within Pages, I would like to use the size attributed to Featured Images for the Home page, and just have 1 image consistently throughout. Thinking this snippet within header.php will have some effect:

    <?php get_template_part( 'template-parts/header/header', 'image' ); ?>

    Thank you.

    Thanks all:

    I guess I wasn’t clear enough.

    – I DO NOT want that huge white bar down the left
    – I do NOT want that huge image on the home page
    – I DO want a small image across the top of every page

    I use the word ‘page’ loosely above. I have determined that there is no way to use a WordPress ‘page’ anywhere to achieve this. So, I converted my whole site to use ‘posts’ instead of pages. And it works swimingly EXCEPT on the home page.

    Take a look at the difference between how each of these are displayed. They are BOTH the identical ‘post’ – see the bracketed (new) at the end of the last paragraph. I just added that to the relevant ‘post’ to be sure.

    http://www.daledietrich.com

    vs

    http://www.daledietrich.com/welcome/

    Both of these SHOULD display identically because they are the same ‘post’ but they don’t. The second link above is how I would like my site to appear to anyone coming in on the first link – well, its close, I would like it to be left justified and take up the full screen but I’m not going to be that picky. If you click on the “Home’ menu item anywhere in my site it takes you to the 2nd link above.

    I tried everything everyone has suggested and most of what was suggested got me this far. The thing is, I could have sworn at one point I achieved my ‘holy grail’ and then after a few tweeks I lost it and can’t remember how to get it back.

    This would all be simpler if there was a way to wipe out the white space on the left and get rid of that huge image on WordPress ‘pages’ but there doesn’t seem to be a way. And it really sucks because I otherwise love this theme!

    …Dale

    • This reply was modified 2 years, 11 months ago by Dale Dietrich.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CSS to remove whitespace on left???’ is closed to new replies.