CSS Problems in IE10 (6 posts)

  1. belfastrab
    Posted 2 years ago #


    I am brand new to WordPress and have spent a hellish few days hammering together a basic custom theme which I have got working.

    I have added a test navigation menu.

    All looks fine in Firefox and Chrome but in IE its of by around 10px.

    I have spent the last 4 hours trying various things to fix it and nothing works. I even thought of using a separate style sheet just for IE as a workaround but I didn't understand the code for that workaround so gave up.

    Please help me before I throw this computer out of a window my patience is wearing very thin.



  2. belfastrab
    Posted 2 years ago #

    Sorry forgot the site is at http://www.nisites.com/wordpress

    Please ignore the custom theme only one I threw together for testing

    [Please ensure that you are embedding links correctly in your posts.]

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    Try sorting out the markup errors.
    If you continue to have problems with IE, consider conditional comment CSS

  4. belfastrab
    Posted 2 years ago #

    Thanks for the reply.

    Fixed the validation errors and still having the problem and conditional commenting doesn't work in IE10 as it just ignores it.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    Conditional commenting does work in all versions of IE. Perhaps your conditional comments are not correct.

  6. belfastrab
    Posted 2 years ago #

    According to these sites it doesn't as it was removed from IE10 granted I didn't try it but failed to see the point in trying something if its well documented that it won't work in the very browser I am having / had problems with.




    I have fixed the issue anyway changed px to em and it worked in all browsers.

Topic Closed

This topic has been closed to new replies.

About this Topic