Support » Plugin: Autoptimize » CSS option off breaks site

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Optimizing Matters


    You’ll probably have to exclude one or more CSS-files from optimization to fix this Artmuns. AO’s FAQ has more info on troubleshooting and how to exclude.

    Feel free to follow up here to share success or failure (in which case I’ll try to assist further)!

    hope this helps,
    frank (ao dev)

    Thank you Frank.

    Yes, I figured that. Having a hard time finding the correct css files though. It seems there are a lot of them. I guess I don’t understand why even deactivating the Autopmtize plugin continues to keep the site broken. The staging site does not have any caching on it and viewing in a “Private window” still shows the CSS issues. There were no CSS issues before using the plugin so I’m confused. But that’s easy for me! I’ll check out the FAQ again.

    Plugin Author Frank Goossens


    morning artmuns;
    had a look and the reason it doesn’t work if AO CSS optimization is off is that the main CSS-file is loaded over http:// instead of https://, causing the browser to refuse to download it;

    excluding the cue CSS can be done by adding wp-content/plugins/cue/assets/css/ to the comma-separated CSS optimization exclusion list.

    hope this helps a bit more,

    Thanks for the reply. Yes I noticed that too on the staging site and when I forced it to load over https it worked fine on the staging. But when I went to the live site, where everything loads over https, the site still broke when I unchecked the CSS option. Perplexing…

    Hi Frank,

    Just tried the CSS exclusion you suggested and that fixed my problem with the Cue plugin. Thank you so much, it’s very much appreciated!


    Plugin Author Optimizing Matters


    you’re welcome artmuns, feel free to leave a review of the plugin and support here! 🙂

    Will do!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘CSS option off breaks site’ is closed to new replies.