Support » Fixing WordPress » CSS not working in Firefox/Mozilla?

  • Hello, (WordPress 1.5) shows up just fine in Safari/Mac (aka KHTML) but when viewing it with any Firefox/Mozilla/Camino variant on the Mac, the page doesn’t work – while all articles and links are actually display, all the nice formatting has gone. It basically looks as if the css is completely ignored. This happens regardless of the theme chosen.

    Opera (8.0 beta on Mac) works fine. However, I can reproduce pretty much the same effect when toggling between “author mode” and “user mode” in the Opera toolbar.

    Any ideas anybody?

    Thanks in advance,


Viewing 7 replies - 1 through 7 (of 7 total)
  • On WindowsXP with Firefox, it looks like no style sheet.

    Instead of using the import to get your style sheet, try this:

    <link rel="stylesheet" type="text/css" href="/wp-content/themes/connections/style.css" media="screen">

    And see if that makes a difference. It’s the “old” way of doing things, but you never know.

    I ran a validation and you have one little bugger:
    Line 125, column 10: end tag for "ul" which is not finished

    But this shouldn’t effect your style sheet.

    *Edit, Lorelle beat me to it.

    Sorry, miklb. If I had only known. 😉

    Looks like it’s a hosting issue – the CSS file is being served up with the wrong MIME type, so Firefox doesn’t know what to do with it.

    Looks very similar to this topic.

    Thanks everybody,

    “wrong mime type / hosting issue” was the correct answer. I was able to edit the “httpd.conf” myself and after I finally realized that I need to clear the cache of my Firefox browser everything worked fine.


    I’m new to WordPress and I really love it, but I cannot get it to display correctly in Mozilla. I’ve tried following these posts and I have checked the mime type files in the cpanel of my hosting server, and it appears correct, ‘text/ css css’ is already listed, soI’m not sure where the problem lies.

    This may be completely stupid to ask, and obviously show my technical shortcomings, but where can i find the “httpd.conf” file?
    Is there a step by step instrutional on how to fix this that would be geared toward people like me?

    I found this post because I was having the same issue with Firefox not seeing the new CSS style I’d just created.

    Clearing the cache took care of the problem. I’m searching the tools – options, but I can’t find anything remotely similar to IE’s “check for newer versions of stored pages.” The only option under cache is to give it a storage size. There must be a way to get around this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘CSS not working in Firefox/Mozilla?’ is closed to new replies.