WordPress.org

Support

Support » Plugins and Hacks » My Custom CSS » [Resolved] CSS not working

[Resolved] CSS not working

  • I already solved this but decided to post because someone else may struggle with this. For whatever reason the css files are being created with only user read/write access. The import directive on the web server requires that the files also be “other” = “read”. I do not know why but this causes the server to not import the CSS. My fix is a one time chmod of the files. Perhaps if the programmer were to code that in as well. (:

    -rw—-r– 1 merlin users 251 Apr 7 18:49 my_style.css

    So the end symptom is simply.. no css works. I am seeing this on a number of multisite css plugins using my apache server configuration.

    http://wordpress.org/extend/plugins/my-custom-css/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Salvatore

    @darkwolf

    Really, i don’t know why… it’s simple a static file imported in browser with standard

    @import url(‘***’);

    css function (like every other css theme files) :/

    Plugin Author Salvatore

    @darkwolf

    Edit: can u try to change in “function makecss()” from:

    return $makecss;

    to this:

    chmod(css_path(), 0664); return $makecss;

    and test again if all works fine?

    Plugin Author Salvatore

    @darkwolf

    Sorry… is best like this:

    $makecss = chmod(css_path(), 0664); return $makecss;

    entire function:

    function makecss()
    {
    	// make my_style.css and write css code!
    	$makecss = file_put_contents(css_path(), "/********* Do not edit this file *********/\n/*\nMy Custom CSS - Maked by Salvatore Noschese\na.k.a. DarkWolf - http://www://darkwolf.it/\n*/\n\n".mycustomcss());
    	$makecss = chmod(css_path(), 0664); return $makecss;
    }

    Yes, I put that code in and it solved the issue.

    Plugin Author Salvatore

    @darkwolf

    Thanks for test and report it 🙂
    I fix it in next release 😉

    Thank you for making such a great app and sharing it with the world. (:

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] CSS not working’ is closed to new replies.
Skip to toolbar