WordPress.org

Support

Support » Plugins and Hacks » [Resolved] CSS Not Working 100%

[Resolved] CSS Not Working 100%

  • SO far this plugin has come closer than ALL other print plugins. Print is such a pain if you ask me. My client had need for a print function that didn’t reset his “sort” options. This plugin solved that issue. Which I am very thankful for.

    My issue is however that the CSS doesn’t seem to be applied consistently. If you look at a single inventory page (ex: http://meltonsales.com/cars-for-sale/2005-ford-f150-lariat-4×4 ) all sorts of madness happen when you try to print it. Spacing is off, styles are off, it turns into a mess.

    I have checked the “use theme css” box. I have even copied ALL css into the two CSS areas. Still nothing.

    Any Ideas?

    https://wordpress.org/plugins/print-o-matic/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Baden
    Participant

    @baden03

    Some Possible Reasons for the Wonky Behaviour:
    1. you are printing only the ‘car_content’ div, and you might have css that references outer elements.
    2. there is css being added via plugin or theme options that are not included in the style.css file

    Try This:
    1. use the Custom Print Page Style section found in the print-o-matic options page to insert exactly the css you need to format the print page the way you want it.

    Let us know if you need further assistance. You are right, print pages can be tricky, but we’ll help get you sorted out.

    Hi, Baden!
    I have the same problem on P-Pro-M 0.9.
    See at my page: http://hpf.ru.com/parish-life/worship/
    I use short-code [print-me target=”.tablepress-id-2, .tablepress-id-3″ do_not_print=”a” alt=”Печатать расписание” css_url=”/css/printtable.css”]
    on this page.
    Custom css-file has no effect on output. When I looked at the html-code of output I found that the <link rel=”stylesheet” type=”text/css” href=”/css/printtable.css”> placed at the end of the file before </body> tag, though it should be in the section <head>.
    Maybe it’s problem cause?

    Plugin Author Baden
    Participant

    @baden03

    Hello Vadim,

    The problem in your case is that you are using the relative url: '/css/printtable.css'.
    Since the blank document that is created for the print does not actually exist, you can not use a relative path. Try using a fully qualified url to the css file you wish to use.

    Please let us know if that works for you.

    Thank you for quick answer, Baden,
    I tried full path [print-me target=”.tablepress-id-2, .tablepress-id-3″ do_not_print=”a” alt=”Печатать расписание” css_url=”http://hpf.ru.com/css/printtable.css”]
    It’s have no effect.
    Also I tried use Custom Print Page Style option. It also has no effect.

    Sorry, the cache has played tricks on me. All ok. Thank you for a great plugin!

    Plugin Author Baden
    Participant

    @baden03

    Glad to hear everything worked out for you. Issue marked as resolved. If you are happy and you know it: clap your hands!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] CSS Not Working 100%’ is closed to new replies.