Support » Plugin: Better WordPress Minify » CSS not loading in Firefox

  • Resolved outpostmm

    (@outpostmm)


    Hello,

    I’m working on setting up your plugin on this site:

    http://dev.mycareertopia.com/

    Initially it worked great, the total number of Javascript and CSS files went from 80 (!) to 24, with smaller size. However, only Chrome was loading the site correctly. Firefox, Opera, and IE were showing missing styling and text on the home page. After some troubleshooting, it looks like if I set the number of minify strings per file to only 4 or above, then Firefox will not style the home page. I have it set to 4 right now so that you can see. It looks like Opera, IE, and Chrome all work fine at 4, but Firefox shows missing styling unless I change that setting to 3.

    Do you know what I can do in order to get that number higher? I’d like to go back to 24 requests, most of the other ones are third party sites that I can’t control but it’s a great savings.

    Thanks

    https://wordpress.org/plugins/bwp-minify/

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Khang Minh

    (@oddoneout)

    That is one weird issue. Maybe you want to try version 1.3.0-beta out?

    https://github.com/OddOneOut/Better-WordPress-Minify/archive/1.3.0.zip

    You just need to use FTP to remove old plugin folder and replace with 1.3.0.

    It looks like Firefox will now work with 4 files, but not 5 or more.

    I’m still looking into this. Let me know if I can help debug anything.

    Plugin Author Khang Minh

    (@oddoneout)

    I will need a temp admin account to test BWP Minify settings, and I assume that you have installed 1.3.0?

    I’m viewing the site with Firefox and it seems to look fine (4 files per string).

    I’ve set you up an account, it should have sent the password to contact@betterwp.net. I did install the beta version you linked to. It does work correctly with 4 files now, although it stops working in Firefox at 5. So, that’s one better than the previous version.

    Plugin Author Khang Minh

    (@oddoneout)

    Hi, I’ve managed to trace down the two CSS files that are causing issue:

    1. dt-custom.less wp-content/uploads/wp-less/dt-the7/css/custom-8aff9937cd.css
    2. dt-royalslider wp-content/themes/dt-the7/royalslider/royalslider.css

    When those two files are combined and printed above these two lines:

    <link rel='stylesheet' id='dt-font-h1-skin5-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300&ver=3.8.1' type='text/css' media='all' />
    <link rel='stylesheet' id='dt-font-h3-skin5-css'  href='http://fonts.googleapis.com/css?family=Open+Sans&ver=3.8.1' type='text/css' media='all' />

    they break either the header or the slider. The first one t-custom.less seems to break the header while dt-royalslider seems to break the testimonial slider.

    I’ve put them into print separately list and your site looks ok now (you can play with the max files per string if you want, but I tested with 10, 15, 20 and all seem to work). But still I’d love to know what’s wrong with those two files. Is there anything special about them? The fact that it only breaks in Firefox is really weird :-/

    Yeah that sounds strange. Those two are theme files, I know that much. I’m a little removed from the site, I’m a developer helping a friend who actually put the site together. I’ll probably notify the theme developers to take a look at this thread and see if they have any information. Thanks for looking into it.

    Hi there,

    I’ve used this plugin for a while (it’s great), but I’ve also started to get no display of stylesheets in Firefox only (Chrome, IE, Safari, etc. work fine).

    I’ve disabled BWP on the live site, but I’ve got an exact copy of the site here:
    http://backlinko.staging.wpengine.com/

    And if you view it in (say) Chrome, you’ll see the stylesheet has an effect (site looks normal) but if you view in Firefox, it’s a white page with no styling.

    I’ve tried all sorts of things (including downloading the release candidate you posted further up this thread) but the error persists. I’ve also minified each stylesheet separately, but this also hasn’t helped.

    Looking at the site I’ve linked to, can you see any reason why it’s breaking?

    One thing of note is that if I right-click and do “Inspect Element” in Firefox, and make *any* edit to the stylesheet (type a random character anywhere), suddenly the whole stylesheet appears and the site displays perfectly.. Which is odd..

    Thanks if advance, if you’re able to offer any advice.

    Plugin Author Khang Minh

    (@oddoneout)

    Do you have Firebug installed? What happen if you inspect element with Firebug and make edit to stylesheet?

    Also right now your staging site seems to be broken for all browsers, I see links to bwp-minify are coming from http://ultra.backlinko.staging.wpengine.com and that domain doesn’t seem to be accessible.

    Is your Site Address (home_url) http://ultra.backlinko.staging.wpengine.com?

    Hi,

    The staging site 100% works.

    The real site (not worth looking at for this problem) is http://backlinko.com

    The staging site is: http://backlinko.staging.wpengine.com

    When I make any edits (Firefox), the stylesheet appears – but before then, the site has no style.

    It works in every other browser.

    (Thanks!)

    Plugin Author Khang Minh

    (@oddoneout)

    Okay I managed to get to ultra.backlinko.staging.wpengine.com. Can you create a temporary admin account on that site for me? Credentials can be sent to contact(at)betterwp.net.

    Oh and by Firebug I mean Firefox’s debug extension, since I’m assuming that you’re using Firefox’s default Inspect Element.

    Hi there,

    How strange!

    What’s your email address? The site is very high traffic, so it definitely can’t be activated on the live site (admin only sounds perfect).

    I will check with the site owner before creating you an admin account.

    Also, I was using “Inspect Element” yes. Sorry, I didn’t get you there.

    Thanks a lot for your help so far – really appreciated.

    Cheers,
    Lloyd

    Plugin Author Khang Minh

    (@oddoneout)

    I managed to get to ultra.backlinko.staging.wpengine.com. Can you create a temporary admin account on staging for me? Credentials can be sent to contact(at)betterwp.net.

    Thanks – I’ve just sent them over.

    Plugin Author Khang Minh

    (@oddoneout)

    Hmm I wonder if the email is lost somewhere?

    Did you check your spam/junk folder?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘CSS not loading in Firefox’ is closed to new replies.