Support » Plugin: Header Footer for Beaver Builder » CSS not being applied on certain page

  • Resolved Payatola2287

    (@payatola2287)


    There are instances wherein the css of the header or footer used with this plugin is not being applied to certain pages but on some pages it is applied, often times only on the homepage.

    I used this plugin on many sites but i just keep having same problems over and over again.

    Any reason for this?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Nikhil Chavan

    (@nikschavan)

    Hello @payatola2287,

    Can you give me a test page link where I can see this error? this will help me debug this error quickly.

    Best,

    Nik

    I believe I have this same issue. Every once in a while the header seems to break formatting when the page is being used as a header. The actual page created to use as the header is fine, just the header in use that has the formatting broken.

    Here are some test pages:

    https://bbheaderfooterproblem.dentalpracticewebsite.com/header-3/
    (the page used for the header)

    https://bbheaderfooterproblem.dentalpracticewebsite.com/
    (home page where page is used for the header)

    It is very odd, when I first use the page as the header, it works and looks fine. If I edit the page used for the header (such as change a padding value etc), it then breaks on the regular website pages where that page is used for a header. I can get it working again if I go in and change to not use a header, edit the page for a while, then reselect that page as the header, but even this is hit and miss I can’t seem to always get it to work. IF I save the row and make a brand new page using that row and select that page as the header, it works, until I edit the page or header again then it breaks.

    Not sure if this is related at all, but just fyi, when I created that website on my multisite as a duplicate of the site where I was having the problems (so I could give you something to test but continue to build the website for the client), I couldn’t even get into the beaver builder editor until I added SSL to that domain. This may have more to do with the domain “dentalpracticewebsite.com” having ssl so any subdomain would need it to route correctly to the editor, I don’t know. Maybe something with SSL and the multisite has something to do with this issue?

    Looking forward to resolve this issue as it is driving me crazy for a while now.

    Thread Starter Payatola2287

    (@payatola2287)

    @nikschavan

    I fixed this by going to the builder of the header and the footer then saving it again. This happens at random. I encountered this problem 2x per site.

    @nikschavan

    I tried the solution posted by @payatola2287 but it did not work for me. I tried opening the builder of the header and saving, and I tried updating from the wordpress editor. Neither way fixed it. I also went to the home page using the header and saved from the builder and updated from the wordpress editor. Both didn’t fix it either. My example links above still show the problem. I hope you can look at this issue. Thank you.

    Is this plugin still being supported?

    Not sure if this plugin is abandoned or what but here is my solution:

    If the header starts to not be formatted correctly, I just duplicate the page I am using for the header (I use this plugin https://wordpress.org/plugins/duplicate-page/).

    I then open the duplicated header and publish it with a new name (Header 2). I go into page builder settings and change the Header Footer to use the new page “Header 2” as the header.

    I then open the home page and save/republish it from Page Builder. Once saved, I check to make sure header is correctly formatted again.

    I then delete the original page I used as the header so as not to get confused later. Then when it happens again, I do the same process but I name the copied page used for the header “Header” so I can just go back and forth between the naming the pages “Header” and “Header 2” as I have to do this fairly often.

    Hopefully there is a fix for this in the works some day…

    Thread Starter Payatola2287

    (@payatola2287)

    This is quite annoying.

    Thread Starter Payatola2287

    (@payatola2287)

    @nikschavan

    Take a look at these:

    Here is the header I want to use:
    http://tempharmonyhealthgroup.com.74-116-115-251.osiriscomm.com

    Here are the pages when I applied it as the header:
    http://tempharmonyhealthgroup.com.74-116-115-251.osiriscomm.com/

    check out the spacing for the menu. I forced the Schedule now button to be right aligned as on different pages, it doesn’t go right aligned.

    Please help or at least give us the reason why this is happening.

    @payatola2287
    I wanted to see the problem from your perspective although I am not the one able to fix the issue. I noticed your links are the same except for a trailing slash. Did you mean to put up another link for the header page?

    Thread Starter Payatola2287

    (@payatola2287)

    Here’s another one that I am working on.

    Homa Page: http://tempmedianetav.com.74-116-115-251.osiriscomm.com/

    About Page: http://tempmedianetav.com.74-116-115-251.osiriscomm.com/about-us/

    you’ll see that in the home page, footer’s css is applied. the icons have no bullets and inline with the text while in the about page, those aren’t. Icons have bullets and in another line above the text.

    Leave the JS in the newsletter.

    Plugin Author Nikhil Chavan

    (@nikschavan)

    Hey Guys, I have just pushed an update to the plugin which should fix this issue.

    Basically, the plugin was previously using methods newer methods from Beaver Builder to render layout markup and the CSS/JS which was causing this problem and as this would be cleared when the BB’s cache was purged this was also bit difficult to reproduce and fix it.

    I am now using BB’s methods for shortcode which should now fix this problem.

    Thanks for the update. After installed, all of my websites on the multisite are using the header and footer from my main admin site and all of the formatting is broken in the site itself. It is a mess. Admin site for multisite:

    https://dentalpracticewebsite.com

    some sites that are now broken

    https://saltlakefamilydental.com
    https://wrightfamilydentalmidvale.com

    Please help! I am on beaver builder pro 2.03

    The one site in the multisite not built with the beaver builder theme is fine.
    https://fourseasonsdentistry.com

    I may have to restore from the backup but I don’t really want to do that. Backup is from Saturday, with individual pages backed up daily so I can get back to before I updated beaver builder header footer, but hopefully there is just an easy fix.

    • This reply was modified 3 years, 10 months ago by greenrhyno.

    Ok I downgraded Beaver Builder Pro from 2.03 to 1.11.1 and then I had to go in and update a page from the beaver builder editor on each website and everything is working again. I am not sure if I can to to a lower version 2 install of Beaver Builder, but with 1.11.1 it is working. I haven’t had time to see if the formatting issue with header footer is solved but I will report any problems.

    I am not sure if the conflict on the headers and footers was with the header footer plugin or with a different plugin. All I know is the headers and footers were showing from the main multisite site and the formatting on all the websites was completely broken and I could not edit or save from the builder itself. None of the modules showed up when I hit the add button and the done button did nothing.

    Now that I am back in the editor, I see that I was using a beaver builder pro version 2 prior to 2.03 so it was definitely a ver 2 version previous to 2.03 update to ver 2.03 that broke everything.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    NUTS. Now I’ll need to review all of the author’s replies…

    @nikschavan I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘CSS not being applied on certain page’ is closed to new replies.