Support » Fixing WordPress » CSS missing for external access

  • Resolved rsturgill


    This isn’t intended to be a question about networking. Instead, I need to understand how WP works to help debug my problem.

    I host my own web server and for security purposes, I deliberately serve pages through a port OTHER than 80. That is, if someone types my web address into their browser (, it automatically gets translated into a different port number ( before it hits my router. I’ll spare you the details of how this is done with DNS, but it’s been very effective in avoiding amateur hackers.

    While this has worked for almost everything on my website, I find that WP doesn’t work with this scheme. Instead, I can access the blog, but none of the CSS. When I access the blog inside the network (using a hosts entry), the blog and CSS are served correctly.

    Any insight into the interaction with the CSS that would explain what I’m seeing? My next (ugly) step is to start tracing through access logs on the server, though that may not explain much. Ugh.

    Many thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Why don’t you try just hardcoding the port into the call to the css file, like this:

    <link rel="stylesheet" type="text/css" href="" />

    Makes sense, Trisha. Um, where is this call found? I searched my entire wp directory… Thanks!

    I’d like to populate my thread with the solution, in the event that someone stumbles on the same problem. It was relatively simple. Add the TCP port number to the URLs for both the blog address and the WordPress address.One additional complexity is that I redirect (302) my URL through a free DNS URL. This free DNS URL needed to be entered into the WordPress address field with the TCP port.

    I have this exact setup, and this exact problem. What do you mean by “blog address” and “the WordPress address” in your solution above? If I type “” in the browser on a machine outside my network, it still doesn’t work. It turns into, which of course can’t be resolved. Directly accessing files from my web server works fine. It’s wordpress somehow redirecting things.

    ok, answered my own question… talking about the Admin->Settings page. Changed it there as suggested and it works now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘CSS missing for external access’ is closed to new replies.