Support » Plugin: Better WordPress Minify » CSS Minification not working for me

  • Resolved theunvarnished

    (@theunvarnished)


    I am currently using minqueue but want to move away from it. I have tried using bwp-minify on my site theunvarnished.com but I can’t get the CSS minification to work for me. The js minification is working great and everything is in the footer where it should be. When I start working on the CSS minification using the manage queue I notice that even when I try to ignore some CSS files they are still being minified or at the very least they are being ignored in the footer when I know the CSS file started in the header. How do I prevent the css files from being moved to the footer? I can use bwp-minify if I don’t do anything to the css files but if I have to do that I’d rather stay with minqueue.
    Any help would be appreciated…..

    Theunvar

    https://wordpress.org/plugins/bwp-minify/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Khang Minh

    (@oddoneout)

    Hmm not sure if I have recommended you to try out version 1.3.0RC1 before?

    http://betterwp.net/332-bwp-minify-1-3-0-rc1-is-available/

    That is actually what I am using. I meant to say that above. I am using 1.3.0 RC1 but the CSS files keep being ignored in the footer. To me that means that bwp-minify moved them to the footer because they were not there originally. How do I prevent my CSS files from being moved to the footer by the plugin…..?

    Thx,

    J

    Plugin Author Khang Minh

    (@oddoneout)

    BWP Minify only moves files to resolve dependency, but in your case it’s CSS so that’s unlikely the cause. Do you happen to change CSS files’ positions via the Manage Enqueued Files admin page?

    theunvarnished

    (@theunvarnished)

    I have not yet given up on bwp-minify. Let me try this again. When I try to use version 1.3.0rc2 I get a problem on the scripts side with a plugin called WPFront Scroll Top. If I check minify js automatically in General Options then scroll to top does not work. Even if I set all scripts to be ignored it does not work. It only works if I uncheck minify js automatically in General Options. I thought I would try to use “Only allow certain media files to be minified” as described by you in betterwp.net. How would I use that code? Where do I put it? In what files….functions.php or some other file? I have tried it in functions.php and pit in the array of handles of the scripts I want minified and nothing happens. What am I missing…?

    Thanks. theunvarnished.com

    Plugin Author Khang Minh

    (@oddoneout)

    I’m testing that ScrollTop plugin and it seems to work. Do you have a dev site that I can debug?

    Hello Khang,

    Thanks for the response (just got it). I have moved away from BWP minify and over to autoptimize which is the smoothest working of all the minify plugins I have tried. It just seems to like my system. I think that the problem was probably something to do with my site structure or some of the plugins I am using. Unfortunately I ran out of time to troubleshoot.

    Thanks again for the response!!

    theunvarnished.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘CSS Minification not working for me’ is closed to new replies.