Support » Plugin: Classic Editor » css issue with classic editor

  • Resolved frenchomatic

    (@frenchomatic)


    After installing wordpress 5.0 and the classic editor, the text in many popular visual editors that people have already become white when trying to edit it- this piece of css in the core wp-includes/css/editor.min.css creates problems –

    .js .tmce-active .wp-editor-area{color:#fff}

    Basically white text on a white background

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    This sounds like a JS bug after upgrading WordPress. Could even be a caching related issue. Perhaps try holding down Shift and reloading the page a few times. That may “nudge” some caches to be refreshed.

    If that doesn’t work, could you look for JS errors in the browser tools? There will probably be clues about what’s going on.

    Thread Starter frenchomatic

    (@frenchomatic)

    I have emptied caches several times and when I change that css to #000 is shows normally. Also this creates issues in the Genesis framework

    .tmce-active .quicktags-toolbar{display:none}

    It means you don’t get your normal tool bar. Removing that and in genesis the tool bar appears. Why would you want to turn that off anyway?

    • This reply was modified 2 years, 7 months ago by frenchomatic.
    Plugin Author Andrew Ozz

    (@azaozz)

    .tmce-active .quicktags-toolbar{display:none} hides the Quicktags buttons (the [B] [I] etc.) when the Visual tab is selected. Otherwise you will see both toolbars.

    Your problem is caused by a JS error on that page. Open the browser tools (right-click, then “Inspect”) and check for errors in the “Console” tab there.

    • This reply was modified 2 years, 7 months ago by Andrew Ozz.
    Thread Starter frenchomatic

    (@frenchomatic)

    Ok – I see the issue – my security was failing to load the resource and was giving a 403 error.

    Basically in wp-inlcudes I used an htaccess which did this. as I now use ninja I probably don’t even need that anymore.

    Order deny,allow
    Deny from all
    <Files ~ “.(xml|css|woff|svg|ttf|pdf|ico|jpe?g|png|gif|js|html_gzip|html|old)$”>
    Allow from all
    </Files>
    <FilesMatch “\.(php|php\.)$”>
    Order Allow,Deny
    Deny from all
    </FilesMatch>

    • This reply was modified 2 years, 7 months ago by frenchomatic.
    Plugin Author Andrew Ozz

    (@azaozz)

    Ah, glad you figured it out 🙂

    Yeah, that .htaccess may bring more troubles in the future.

    • This reply was modified 2 years, 7 months ago by Andrew Ozz.
    Thread Starter frenchomatic

    (@frenchomatic)

    Like you i thought caching and was banging away on cloudflare and W3TC. Didn’t think to inspect what js was firing or not as the case may be. Your plugin is a god send because none of my clients want to learn the new editor – frankly it is a big backward step. There are really good visual editors already if people want to use them. Anyway, thanks for your persistence.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘css issue with classic editor’ is closed to new replies.