Support » Plugin: Fast Velocity Minify » CSS Ignore List Login Page

  • Resolved John Garvin

    (@atomiccherry)


    It seems that the issue affecting CSS in the ignore list, although corrected in the latest version, is still affecting the login page.

    I am enqueuing custom styles via theme function for the login/register page however these styles are no longer appended to the html even when added to ignore. Neither are the style sheets being merged when left off the ignore list.

    Just wanted to bring that to your attention in case your tests result in the same issue. But will continue to test further locally. Only solution now is to simply disable the CSS merging altogether.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Raul Peixoto

    (@alignak)

    Is the login page the standard wp-admin login page or some other page you have created on the frontend where you have a custom login?

    How exactly are you enqueuing your custom css and js files on your theme functions.php file? Can you paste the relevant code here?

    Plugin Author Raul Peixoto

    (@alignak)

    An can you also try v1.4.8 to see if it fixed it for you?

    Hi Raul,

    Sorry to say, looks like I’m back to square one. Login page still affected by CSS issue. Now JS seems to be having the same problem where before it was working.

    Plugin Author Raul Peixoto

    (@alignak)

    Hi, sorry that it didn’t fix your problems.
    There have been some people also reporting similar issues, but all of them reported back saying it’s fixed on 1.4.8… so you’re the last person left.

    I haven’t done any changes on the js side, but I wonder what the problem is.
    As for the css on the login page, can you please reply to my question so I can understand the issue:

    Is the login page the standard wp-admin login page or some other page you have created on the frontend where you have a custom login?

    How exactly are you enqueuing your custom css and js files on your theme functions.php file? Can you paste the relevant code here?

    Also, are you testing this on a real website or doing it locally without a full qualified domain?
    Would you be available to send me a full dump of both your installation and database for further testing (dropbox, google drive or whatever)?

    I’m using the default WP login page and enqueuing custom styles:

    function custom_login() {
    	if ( get_theme_mod('login') == 'light' ) :
    		wp_register_style('light', get_template_directory_uri() . '/assets/admin/custom-login-light.css');
    		wp_enqueue_style('light');
    	else :
    		wp_register_style('dark', get_template_directory_uri() . '/assets/admin/custom-login-dark.css');
    		wp_enqueue_style('dark');
    	endif;
    }
    add_action('login_head', 'custom_login');

    Using same logic for frontend css and js. Running locally in MAMP environment, PHP 5.6.x.

    Even if I disable JS processing/merging, now plugin merely being activated breaks my js.

    I’m sure it’s probably related to the theme or plugin conflict (though was working great previously). Just haven’t had a chance to spend too much time debugging.

    Before you spend any time on this, I’ll run through some scenarios and attempt to debug with my theme and/or plugins deactivated.

    I appreciate all the hard work you’ve put into this amazing plugin.

    Okay, I see the issue with the JS. Even though I have not selected the option to defer scripts, all scripts not on the ignore list are being deferred even though I also have the merge processing also disabled.

    It is also removing line breaks between <script>…</script> calls.

    Still could be an conflict with my theme or another plugin. Continuing to test.

    Plugin Author Raul Peixoto

    (@alignak)

    Sorry fr the trouble, have fixed this on v1.4.9 and added an option if you wish to disable js processing on the login page too.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘CSS Ignore List Login Page’ is closed to new replies.