WordPress.org

Forums

CSS Help to fix theme (10 posts)

  1. ikthius
    Member
    Posted 6 years ago #

    Hi,

    I was wondering if someone can help me with a piece of css to help make my theme work better.

    My main site is coded through HTML and has a table, my wordpress theme is XHTML and is just divs, (the main site was there first)

    my main html pages expand nicely when there is more content, but my wordpress page does not..

    I have my wrapper set at height:3000px cause if I have height 100% my side borders do not stretch down to the bottom of where the div should end in my template file before being broken up into PHP files...

    here is my test blog, http://www.pfs-ifa.co.uk/demo/resources/wordpress/

    you will see the side borders keep going down, but I need this to be dynamic as in the size of content.

    could someone please help...

    also I have my body set at 100% and wrapper at 100%

  2. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    At least two things wrong with theme set up:

    1) in <div id="header"> you have a div inside a link, a - delete that div or move it outside of link code
    <a href="http://www.pfs-ifa.co.uk/demo/resources/index.php" class="y"><strong><div class="currentY"></div></strong></a>
    to
    <a href="http://www.pfs-ifa.co.uk/demo/resources/index.php" class="y">??what's suppposed to be here??</a>

    2) Delete the first reference below to style.css in header.php There's nothing wrong with having two stylesheets to call from. But there's something very wrong with putting your source code in style.css

    <link rel="stylesheet" type="text/css" href="style.css" media="screen" />
    <link rel="stylesheet" href="http://www.pfs-ifa.co.uk/demo/resources/wordpress/wp-content/themes/pfstheme/style.css" type="text/css" media="screen" />

    to
    <link rel="stylesheet" href="http://www.pfs-ifa.co.uk/demo/resources/wordpress/wp-content/themes/pfstheme/style.css" type="text/css" media="screen" />

  3. ikthius
    Member
    Posted 6 years ago #

    that div was supposed to be an image that stays on to say what area they are in, but I just renamed the class.

    I changed the stylesheet link rel, to what you suggested but it is still the same

  4. ikthius
    Member
    Posted 6 years ago #

    I know my wrapper class is the problem, I need to give it a size or my borders for the wrapper do no go much further than the header.

    100% does not work, and leaving it blank has the same effect.

    so I have set it to 3000px just now, but how can i get this to increase as the post length increases?

    please help

  5. Chrisber
    Member
    Posted 6 years ago #

    The best approach is to use a vertically scrolling background image to create the borders. It will allow your borders to expand and contract to fit your content without specifying a height. Google "css faux column technique"

  6. ikthius
    Member
    Posted 6 years ago #

    it never really helped, it broke up the theme and it was a mess.
    I even tried it with the body being a different colour, but even that did not seem right.....

    looks like this is not going to be able to be fixed to keep the border on the wrapper, although the wrapper is the really the largest container apart from body, so not sure why it wont stay 100%???

  7. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    Try adding
    <div clear="all">&nbsp;</div>
    before the closing wrapper div in source
    and delete wrapper height:3000px in style.css

  8. ikthius
    Member
    Posted 6 years ago #

    mercime, this has helped, but this only goes down half way, or to be precise, it goes about 20px below the sidebar, which will probably be the section that will be smallest, as comments will be enabled.

    but the side borders do not go down to the bottom, although now a good bit further,

  9. ikthius
    Member
    Posted 6 years ago #

    I fixed my problem,

    I woke up 2am this morning having an epiphany.....
    in the wrapper have the overflow:auto, this would show me what was going on, so now it is overflow:hidden, no scrollbars, but it works perfectly now..... I don't know why I never thought of that in the first place....

    so the borders now only go to the end of the footer, and not beyond as I have taken the wrappers height away.

  10. veka
    Member
    Posted 6 years ago #

    OK, cool that your problem fixed yourself. as for me I have mini lesson for the future.

    respect from veka

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags