WordPress.org

Forums

[resolved] CSS file not being accessed (5 posts)

  1. usermonster
    Member
    Posted 10 years ago #

    Hi, I just installed WP on a new hosting provider; my blog is currently hosted elsewhere using MT. I want to set-up the WP version before I change nameservers to point at the WP version. Problem is all the WP settings are pointing to the domain name that leads to the current MT blog, which means I'm getting the index.php page without the CSS file attached to it (wp is looking for the CSS file at the other server). So, basically, I can't make adjustments to the CSS file and then see how it looks. I installed WP using an automatic installation through the control panel, so I'm assuming it grabbed some environmental info and plugged them in (the new hosting account is setup with the domain name that is currently hosted somewhere else -- this is pretty common when you're switching hosts). Is there any way I can change where WP inserts default domain paths to a temporary one? I've been looking through the config files but haven't found a place for it.
    I hope this makes sense to someone!
    Thanks
    Thanks

  2. usermonster
    Member
    Posted 10 years ago #

    Ah, perhaps in something called "options" in the admin screen!

  3. serendipity
    Member
    Posted 10 years ago #

    Well, I don't know what this automatic install thingy is. But just have a look inside index.php and look where it looks for the css file. It seems to find wp-blogheaders, so it should find wp-layout.css too.
    And yes, read through all the options, and change the defaults if necessary.

  4. Root
    Member
    Posted 10 years ago #

    Well with some hosts they activate a temp name pending the update to the dns. In some cases the temp name does not carry full account status and you and WP can not in fact access all the files. This can be tricky if you want to keep your old site running *until you are ready*. You may need to email your hosts for the heads up.

  5. usermonster
    Member
    Posted 10 years ago #

    Changing the URL to the temporary server in the options menu did the trick. When I'm ready to point the nameservers to the new host, I'll switch 'em to the actual domain name.
    Thanks all!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.