WordPress.org

Forums

CSS Broken after Minify?? (3 posts)

  1. Lins
    Member
    Posted 2 years ago #

    I ran through some instructions from this page at WP-Tuts on setting up & using W3 Total Cache. http://wp.tutsplus.com/tutorials/the-ultimate-quickstart-guide-to-speeding-up-your-wordpress-site/
    This has been great for me before.

    Now my fancy dropdown menus are broken. When I inspect element, the element style itself has display:none; visibility:hidden; on it.

    I think these may have been inherited from another element when I minified all the CSS together? Is that even possible? My brain is fizzled at the moment. I really need them to work though, breaking them on a client's busy site is awful.

    I tried selecting the menu items very specifically and changing css to display:inline; visibility:visible; but that's not helping. I have to leave for the afternoon & it broke at the last minute... so maybe I can look into targetting the css more specifically.

    I've since deactivated the plugin & thrown my hours away.

    See the dropdown menus here: http://www.wemakestuffhappen.com

    Thank you in advance if you take a look for me. Headache. :(

    Lindsay

  2. andy2grant
    Member
    Posted 2 years ago #

    just deactivate the minify plugin and then wait for cache to get refreshed . It will work then . Minify stops various scripts to run . If you have animated effects and java then avoid that plugin .

  3. wp-fan
    Member
    Posted 2 years ago #

    Using minify is always a bit tricky. I experience on my site that not all .css or .js work after being minified. But, from my experience, you do not have to switch minify off all together.

    My solution:
    1. In "General" tab, switch minify from "automatic" to "manual".
    2. A help-button will show up in "Minify"-tab.
    3. Push "help"-button in minify tab, select the .js and .css manually which can be included in the minified file. Deselect those .css and .js files of those modules which did not seem to work correctly in automatic mode.
    4. Check the result on your site.

    Make sure logged in WP admins do get to see the minified results instantly (there is an option on the minify page to toggle this behavior).

    Kind regards,

    Thomas

Topic Closed

This topic has been closed to new replies.

About this Topic