CSS and Mozilla (4 posts)

  1. paulzag
    Posted 12 years ago #

    I have a problem with CSS and mozilla that I don't think is strictly WordPresses problem. I suspect it is something to do with mime.types but I've updated the apache entry to make css files text/css.
    If I embedd the style like this http://www.wealthesteem.org/nested-float.php then it appears fine.
    See http://www.wealthesteem.org for the normal problems. IE does not have the problem (because it is barely standards aware!)
    This is so far a problem only with Mozilla (and gecko) browsers. If you have any suggestions I'd appreciate them.

  2. Dougal Campbell
    Posted 12 years ago #

    Your web server is serving up your CSS file as MIME type 'text/plain' instead of 'text/css'.
    Try creating an '.htaccess' file with this line in it:
    AddType text/css .css

  3. Anonymous
    Posted 12 years ago #

    Thanks dougal. At 4am local time NOTHING was working. This morning I removed and re-applied my httpd.conf changes it suddenly started working after 30 mins.
    I even tried the .htaccess file and it didn't "take" last night either.
    For people searching the forum in the future (I wont be the last), dougal correctly identified the problem.
    Browsing directly to the css file in Mozilla and looking at Page Info (Ctrl+I) shows the type.
    1) If you control your server http://apache-server.com/Podium/show.php?p=apache-howitworks&slide=10
    2a) If you don't controll your server, tell your server admins to configure css files as type text/css
    2b) Until your admins do that use dougal's .htaccess workaround

  4. DianeV
    Posted 11 years ago #

    I just solved the same issue with Gecko-based browsers not displaying CSS styles in XHTML files: http://wordpress.org/support/3/11412
    On our virtual private server, the MIME types are controlled by a file called mime.types, which is in the same directory as the httpd.conf file.
    Found the precise coding here:
    Add this to the mime.types file:
    text/css css
    then restart apache.
    Presto, fixed.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.