Support » Fixing WordPress » Crunching problem in WP 2.7

  • Hello, well I’m having a little problem. When I upload a picture using the image uploader on the post or direct in the media library, the pictures that I upload aren’t crunching.

    I check my upload folder to CMOD setting 777 and nothing. Also the image is uploaded but not crunched.

    Please help me.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I try to use the flash and the bwoser uploader but none of the two above, works.

    nice community 🙂

    I have the same problem, also WP 2.7
    At first it worked fine, since last week it doesn’t work anymore.
    I did change some things in the theme but nowhere else…

    When I upload a new picture it sais on the screen that it is crunching, but no smaller images are generated, I checked via ftp.
    Also my CHmod is 777, and the bigger images do upload fine, so that is not the problem. And there is enough disk space left.

    Does anybody else have this problem and – maybe – have a solution?
    Right now I’m using Photoshop scripts to downsize and rename my images and then I upload the smaller sizes via FTP – which is a pain…


    I’m now having this issue with WordPress 2.8. However my images are not uploaded (the original sizes). The folder is created, but the image is not uploaded.

    same problem here with 2.8.4 on both my blogs.
    Only difference to many reports is, that the file is uploaded (it’s already web-sized) but during crunching there is an error.
    I tried everything I could find (CHMOD, deactivate plugins etc.) but nothing worked.

    I hope I didn’t oversee the thread with the solution… couldn’t find any.

    simon_k: you are going to have to cut and paste the error message into this forum to get a definitive answer from anyone.

    But, a very worthwhile thing to try is to begin your tests with a very small picture. An 80×80 pixel .jpg would be ideal (anything smaller is fine, too).

    Does it not work with ANY size image? ie: do smaller images work but larger ones do not?

    Try a smaller image (smaller in picture size not file size), see if that works.

    Depending on your host, you may be running into the process memory limit when crunching. I get this all the time with 1&1. I just have to resize the image to a smaller overall size and it uploads/crunches just fine, but with larger images it will just upload them and die when crunching.

    You can also check your error logs to see what error php is putting out.

    For anyone reading this and running into upload memory size issues, I had resigned myself to having to resize every image before uploading after testing both the built-in WordPress Media Management (which is being totally rewritten for the next major version) and the plug-ins I tried. What a huge pain.

    Instead, I found that NextGEN Gallery plug-in lets me upload the full resolution photo straight off the camera.

    thanks for your answers.

    Both blogs are hostet on a 1&1 server, pictures are resized to 1000px before uploading and the full size version is uploaded without any problems. I can even insert them into posts.
    The problem is that the 576px (medium size) version is not created. I guess that’s what “crunching” does, right?

    I tried to figure out how to get wordpress to give me a detailed error, but the php.ini lies somewhere on the server where I can’t access it.
    The php info says that display_errors is on, but the error log is not defined and log_errors is off.
    The only error I get is the “HTTP error” when uploading.

    Why does WordPress have no error log? I thought a software that’s under constant development alwas logs errors…

    @adiant: Maybe I should just talk to 1&1… but I can’t imagine that a 1000px image is too much to convert.

    Did anybody solve this problem yet?
    I didn’t. Even downgrading to 2.7.1 didn’t help as well as reuploading all files.
    This really sucks, I need to upload some pictures…

    ok, have been playing around a little more – works with pictures smaller than 1000px wide (800 works, 950 doesn’t).
    Strangely there is no problem with file size – my 1000px pics are 80-150kb and I successfully uploaded a 275kb 800px wide picture.

    Same problem here. Running version 2.8.4.

    Indeed seems to have to do with the resolution of the image:
    I uploaded a 1200×800 608kB image just fine while having problems uploading an 2000×1333 image of only 82kB.

    Wonder what’s causing this and if there’s a solution for uploading large images.

    Hi everyone, i had exactly the same problem (version 2.8.5) and tested a couple different “solutions” that i found by googling. None of them worked for me.

    At last i solved the problem and for me it was that the “Store uploads in this folder” was set to “wp-content” by default. When i checked my webserver i saw that all the pictures that i uploaded earlier was in fact stored in that folder, even though i got the “http error” when the statusbar was on “crunching”.

    When doublechecking the URL to the images that has been published on the blog (but could not be loaded) they were in fact pointing to “/wp-content/uploads”.

    I changed the “wp-content” to “wp-content/uploads” and then the function for image uploading started to work fine.

    Step by step (worked for me):

    1. When logged in on your blog, choose “Settings” and then “Miscellaneous”.
    2. Change “Store uploads in this folder” to “wp-content/uploads”



    Please HELP! I’ve an image upload issue with version 2.8.6 using 1&1. I get the..’Cannot find image….’message. Do you think I need to resize too or is there another fix?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Crunching problem in WP 2.7’ is closed to new replies.