Support » Plugin: Contextual Related Posts » crp_title is empty after update to 3.1.0

  • Resolved webcrow

    (@webcrow)


    After updating to 3.1.0, <span class = “crp_title”> is empty. Back to 3.0.7 was the solution

    • This topic was modified 5 months, 4 weeks ago by webcrow.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Ajay

    (@ajay)

    Please can you post the HTML you’re seeing – an empty span means no title is displayed?

    Thread Starter webcrow

    (@webcrow)

    Check it here.
    Das könnte Sie auch interessieren

    [ link moved to correct field ]

    Regards

    • This reply was modified 5 months, 4 weeks ago by webcrow.
    • This reply was modified 5 months, 4 weeks ago by Jan Dembowski.
    Plugin Author Ajay

    (@ajay)

    Is this the old version installed right now or the new one?

    Because I can see e.g. <span class="crp_title">90 Jahre Ladenstraße Onkel Toms Hütte</span>

    • This reply was modified 5 months, 4 weeks ago by Ajay.
    Thread Starter webcrow

    (@webcrow)

    Now installed the 3.1.0.
    You are right.
    I checked again and find out than the span only empty when I logged in.
    Please have a look.
    https://ibb.co/rZSzxRF
    https://ibb.co/23Z7zzf

    • This reply was modified 5 months, 4 weeks ago by webcrow.
    Thread Starter webcrow

    (@webcrow)

    But the client send me this https://ibb.co/dWPYTW5
    He was not logged in.
    https://www.stadtrand-nachrichten.de/programm-volkshochschule-steglitz-zehlendorf-2022/

    • This reply was modified 5 months, 3 weeks ago by webcrow.

    I have the same issue. I’m using v3.1.0 version and I dont have any titles in my related posts (logged in or logged out)

    Here you can see that crp_title is empty.

    a href=”https://www.mypage.com/my_article&#8221; rel=”nofollow noopener” target=”_blank”>
    <span class=”crp_title”>
    </span>
    </a

    • This reply was modified 5 months, 3 weeks ago by juanga92.
    • This reply was modified 5 months, 3 weeks ago by juanga92.
    Plugin Author Ajay

    (@ajay)

    @juanga92

    I’m wondering if this is a specific settings issue as I can’t replicate it. Can you make a note of what your settings are and then reset it using the button at the bottom. Once done, please check the outputs, and reapply the settings you had earlier.

    problem solved: https://ibb.co/bXQH687

    Plugin Author Ajay

    (@ajay)

    @sultanes

    Thanks. That’s interesting as it is used to limit characters. Is your site a non-English one by any chance and so the plugin is probably unable to figure out where to cut it off? I might need to run some checks to workaround in case this happens.

    @juanga92 @webcrow
    Please can you also check what was posted above?

    I do not speak English.

    It’s easy to set a limit like in the screenshot and the problem won’t be: https://ibb.co/bXQH687

    Limit post title length (in characters) “0” means that no title is entered

    Plugin Author Ajay

    (@ajay)

    @sultanes

    Thank you. I filed a bug report. Setting it to 0 should return the original string but it returns a blank title.

    Is there anything new on the topic? I had the same issue and got a PHP error reported by Query Monitor because of the empty field. Currently running the old version of CRP (3.0.7) until there is a fix.

    To limit the post title length in settings didn‘t solve the problem for me.

    • This reply was modified 5 months, 1 week ago by fgruen.
    Plugin Author Ajay

    (@ajay)

    Can you tell me what the exact error in Query Monitor was?

    If you’re able to edit the files, can you edit this line: https://github.com/WebberZone/contextual-related-posts/blob/cb347764b8f83b8b56e40fd8fcb83562cdbaca52/includes/tools.php#L146

    it should read return $string instead of what you see there

    The error message says:
    Can’t find FULLTEXT index matching the column list

    error code:
    qmdb

    Example Query:

    SELECT wp_posts.*, MATCH (wp_posts.post_title,wp_posts.post_content) AGAINST ('Einfach erklärt: Smarthome?') as score
    FROM wp_posts
    WHERE 1=1
    AND ( ( wp_posts.post_date >= '2021-01-03 00:00:00'
    AND wp_posts.post_date <= '2022-01-03 14:21:11' ) )
    AND wp_posts.ID NOT IN (2170,46176,51516,52842,32934,52848,79804)
    AND wp_posts.post_type = 'post'
    AND ((wp_posts.post_status = 'publish'
    OR wp_posts.post_status = 'inherit'))
    AND MATCH (wp_posts.post_title,wp_posts.post_content) AGAINST ('Einfach erklärt: Smarthome?')
    ORDER BY score DESC
    LIMIT 0, 5

    Unfortunately, I’m not an expert. So editing files is not an option. If the issue is not going be solved I will have to look for an alternative plug-in or solution.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.