Support » Plugin: Cloudflare Flexible SSL » Cross promotion fail

  • gutenbrick

    (@gutenbrick)


    I’ve been using this for a while on several sites.

    Now since a plugin contributor got added and touting Shield Security, when I dismiss that message, deactivate, and completely delete, my site wont work and get into infinite loop again.

    TBH, this plugin isn’t even needed anymore, but whatever.

    Leaving at 1 star until you fix. Once you fix, I’ll edit the review.

    • This topic was modified 6 months ago by gutenbrick.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Paul

    (@paultgoodchild)

    Are you saying that when you disable the plugin, the problem (for which the plugin was originally built to address) returns? That’s like turning off a fan on hot day, and complaining that it’s too hot. Here’s the fix: reactivate the plugin.

    Also, don’t think to review-blackmail us as some sort of motivation to fix your problems. You can leave the review at 1 star for as long as you wish.

    There are few things worse that ridiculous reviews like this, posted solely for the hateful purpose of dragging people down.

    For future reference, the original review content:

    I’ve been using this for a while on several sites.

    Now since a plugin contributor got added and touting Shield Security, when I dismiss that message, deactivate, and completely delete, my site wont work and get into infinite loop again.

    TBH, this plugin isn’t even needed anymore, but whatever.

    Leaving at 1 star until you fix. Once you fix, I’ll edit the review.

    gutenbrick

    (@gutenbrick)

    Im not trying to “review-blackmail” you. I’m just saying that none of the problems existed until this Security Shield promo, and that I’m happy update the review if you can help me figure out why this is happening.

    If I’m wrong and it’s user error, I’ll 100% call myself out and apologize for jumping to conclusions….but I’ve setup Cloudflare on several sites (over 30) with SSL, and it works fine with no loop, so I simply don’t need this plugin anymore.

    So the fact remains that when I uninstall it, everything breaks.

    A plugin shouldn’t do that on an uninstall/deletion.

    Is there something being stored in the database I can delete?

    Plugin Author Paul

    (@paultgoodchild)

    Sorry, but stating:

    Leaving at 1 star until you fix. Once you fix, I’ll edit the review.

    … is actually review blackmail, regardless of what you say.

    But back to your trouble. When you have problem, we’re meant to use the support forums, not 1* reviews, to elicit support ( – support that is free & volunteered).

    Here is a snapshot of the plugin as it has been since the day the plugin was first published to WordPress.org:

    05.20.2019-15.45.28

    If for whatever reason that image link doesn’t appear, please go check the plugin FAQs for the question that reads:
    “What happens if I disable this plugin AFTER enabling Flexible SSL on Cloudflare?”

    So it looks like you’re probably doing it wrong and you haven’t configured your site for SSL properly, because if it was correctly configured for SSL, then this plugin would have ABSOLUTELY NO effect. None whatsoever. If you can read the PHP, you’d see that for yourself. You’d also see that the plugin doesn’t leave any “settings” pertaining to SSL on the site, so once the plugin is removed, ANY and ALL effects it previously exerted are gone entirely. It’s meant to be that way, as we’d expect sites on Flexible SSL to be transitioned to full SSL and I didn’t want this plugin to interfere when that happened.

    This whole exchange could have been far more pleasant.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cross promotion fail’ is closed to new replies.