WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Jetpack by WordPress.com
[resolved] [closed] Cross-origin error with photon (7 posts)

  1. macgamer
    Member
    Posted 3 years ago #

    With photon enabled, I get the following error (in chrome) when trying to place an image (from wp_get_attachment_image_src) on a canvas. This only happens with images served from i*.wp.com (which is currently all of them unless I can find a way to override them)

    Unable to get image data from canvas because the canvas has been tainted by cross-origin data.

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    Could you post your site URL as well as some examples of the images returning the error, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  3. macgamer
    Member
    Posted 3 years ago #

    I'm trying it via a virtual machine test site right now. When I take the site live I'll email.

  4. macgamer
    Member
    Posted 3 years ago #

    Here's a page set up to use photon, which returns the error (in Chrome).

    http://www.controlcommandescape.com/games/?photon=1

    If you omit the parameter, you can see the version that uses local files.

  5. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    Thanks! It seems to be working for me though, in Chrome, Firefox, and Safari.
    http://i.wpne.ws/N5iO

    Could you let me know one of the problematic image URLs?

  6. macgamer
    Member
    Posted 3 years ago #

    No that screenshot proves it is not working; the javascript is terminating. Check chrome's console log. Also see what happens differently when you click on one of the icons from http://www.controlcommandescape.com/games/

  7. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    Oh, alright! My bad, I misread your first post; I thought that the images were not displayed, and returned an error.

    I have forwarded the issue to our Photon expert, and we'll get back to you as soon as we can address the issue.

    Update: this bug has now been fixed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags