Support » Plugin: MetaSlider » Cropping does not work anymore

  • Resolved Alexandra

    (@menthool)


    Hello Support,

    i set up an woocomerce shop with vantage theme and metaslider. All worked finde till yesterday. The slider has 3 photos:Landscape & portrait. With the 100% & Smart Crop option it worked very well.

    Today the height of the slider are changing all the time with the different pictures. I tried everything but cant`t finde the mistake. So i had a look under FF in the Code:

    This is the code on an old site which works perfectly:
    <img class="nivo-main-image" src="http://test/wp-content/uploads/2018/05/karlina.jpg" style="display: inline; width: 1263px; height: 253px;" />

    This is my new site with the same picture and the same metaslider settings:
    <img class="nivo-main-image" src="http://test/wp-content/uploads/2018/05/karlina.jpg" style="display: inline; width: 1263px; height: 1822px;" />

    Don`t know why, but the cropping does not work here as you can see. I set the size in MS to 2000×400 and Smart Cropping and 100%. All the same settings like on my old site.

    I tried the following:
    -Deleted all custom CSS
    -Deaktivated all plugins
    -Tried different pictures with different sizes.

    Perhaps you could give me a hint where to search next.

    Have a nice day

    Alexa

    • This topic was modified 1 year, 5 months ago by Alexandra.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool,

    Thanks for the feedback. We’re taking a look at this now. Can you share a link to your website by any chance?

    Thank you for your reply. You can view the slider here:
    dasliebesschloss.de
    The second picture will expand to the full height.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool,

    We should have a fix out tomorrow. Sorry for the inconvenience. If you need to revert to an older version, you can do so at this link (scroll to the bottom). Deleting the plugin will not affect your slides.

    https://wordpress.org/plugins/ml-slider/advanced/

    • This reply was modified 1 year, 5 months ago by kbatdorf.

    Hi,

    thank you very much for your support! Glad to here that the problem is not somewhere in the theme or my modifications. I will try an older version till an update is out.

    Thanks!

    Revert to Version 3.7.2 fixed my problem. Thank you for the support.

    I was having this same issue, rolled back.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool, @jcostas81

    Can you update to 3.8.1 and see if the problem is resolved? Thanks

    Can report that the cropping problem is fixed in 3.8.1

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool,

    Great to hear. Let us know if you run into any more issues. Have a nice weekend.

    But i noticed just another issue: I am testing the slider with some very different pictures in format and size and set the resolution in ms to 1280 x 800 and flexslider. Now my pictures will be cropped all to a static size.

    But the height of the images are different from the settings in metaslider. I will get a height of 336px.

    If i understand the function of metaslider right, it should cropp pictures of different sizes and resize them?

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool,

    If you have smart crop on, it should crop the image to the exact dimensions you have set in the slideshow. Is this not happening? Can you add it to a test page and share the link here?

    If you have smart crop on, it should crop the image to the exact dimensions you have set in the slideshow. Is this not happening?

    In my case, the size is stretched to 100% as expcted but the height does not follow the setting in MS.

    well, have another try with extreme different sizes. My settings:

    Pictures in use:
    1600×1600
    444×640
    682×1225

    Flexslider,2000×400,Smart Cropping, Stretch 100%, CSS JS On, conflict mode off.

    Result 1263×250

    You can view the result at dasliebesschloss.de

    Have a nice weekend too!

    Alexa

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @menthool,

    It appears to be working correctly. If you crop to 2000 wide and the browser is at 1263px then the height will be relative to the original height.

    If you’re just testing things that’s fine, but I suggest you try to use images larger than your crop size, so they wont appear blurry.

    ah ok, i suspect that is related to the browser resolution. Just a little test with res 1263×400 and tadaa 400 height. Thank`s for the explanation.

    That`s ok i know the “problem” when upscaling , it was just for a quick test but thanks for the advice!

    Everything solved, have a nice and long weekend!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Cropping does not work anymore’ is closed to new replies.