Support » Fixing WordPress » crop feature not working

  • hello

    I’m trying to crop the thumbnails to replace the predefined ones. It’s not working.

    here is what i am doing:
    1. go to media library and choose an image
    2. click “edit image”, select the area i want to crop. In the thumbnail setting box, i select “thumbnail”
    3. click the crop Icon
    4. click save

    Finally, the cropped thumbnail doesn’t change at all. Now, when I test it in post the thumbnail stays the same, as it was predefined, cropped in the middle of the image.

    When i go back to the edit image section, the “thumbnail setting box” disapeared.

    thank you for your help

Viewing 5 replies - 1 through 5 (of 5 total)
  • maybe the problem comes from the theme (

    still investigating… 

    In fact, no it’s not coming from the theme but something really strange with the crop tool :
    it doesn’t work if thumbnail is cropped to it’s exact size :

    I am having this problem too. I had a series of related problems with the Header actually.

    My theme is Bueno. And when I try to upload a header this message would come up: “Sorry, this file type is not permitted for security reasons.” Its happened to others, as I’ve read online, but there is no clear solution.
    I’ve tried logging out, logging back in. Still there.
    I was experimenting with different headers just fine and then–I just can’t anymore without that message coming up.
    NOW when the message doesn’t come up, I can’t crop the image. The image is not even there, but a blank gray box, that isn’t even where the picture would be had it actually uploaded. Instead its up against the upper left of the computer screen. Weird.
    I have tried changing my theme also. That doesn’t work.
    I have tried changing the file extension, that doesn’t seem to work.
    I can’t even upload pictures that I have previously uploaded successfully. Its just NOT working. I don’t know what to do! Where would I begin to solve this problem!? Please be specific! I am lost! Can’t upload images!


    I also have problems with crop funcionality. I want to set several images size for post-thumbnails, but parametrer crop keep image proportions and some images don’t resize as I wanted.

    if (function_exists(‘add_theme_support’)) {
    set_post_thumbnail_size(180, 130, true);
    add_image_size(‘featured’, 300, 281, true);
    add_image_size(‘category’, 200, 140, false);

    Anyone has this problem? Thanks

    We had this issue today and determined that you can’t “crop” an image to the exact dimensions of the original thumbnail. This is because of the way to tool works when it tries to create the new thumbnail the filename conflicts with the existing thumbnail and it fails. Hopefully this issue will get corrected in a WordPress update in the future.

    Also, if you try to create the cropped image and loose your thumbnail, you will want to use a plugin to “regenerate thumbnails”.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘crop feature not working’ is closed to new replies.