Support » Plugin: MailPoet - emails and newsletters in WordPress » Cron sending constant emails

  • Resolved allanit

    (@allanit)


    Hi I am running a Webmin server virtual servers. The virtual server in question has WordPress Version: 5.3 PHP Version: 7.2.17-1+ubuntu14.04.1+deb.sury.org+3 MySql Version: 5.0.12. I have set up Server side cron (Linux cron) which runs every 5 minutes. Each time the cron job runs I get the following email sent to the server user.

    PHP Warning: Use of undefined constant WP_CONTENT_DIR – assumed ‘WP_CONTENT_DIR’
    (this will throw an Error in a future version of PHP) in /home/myserver/public_html/12/wp-includes/load.php
    on line 141

    Warning: Use of undefined constant WP_CONTENT_DIR – assumed ‘WP_CONTENT_DIR’ (this
    will throw an Error in a future version of PHP) in /home/ myserver /public_html/12/wp-includes/load.php
    on line 141
    <!DOCTYPE html>
    <html xmlns=”http://www.w3.org/1999/xhtml&#8221; dir=’ltr’>
    <head>
    <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″ />
    <meta name=”viewport” content=”width=device-width”>
    <title>Requirements Not Met</title>
    <style type=”text/css”>
    html {
    background: #f1f1f1;
    }
    body {
    background: #fff;
    color: #444;
    font-family: -apple-system, BlinkMacSystemFont, “Segoe UI”, Roboto, Oxygen-Sans,
    Ubuntu, Cantarell, “Helvetica Neue”, sans-serif;
    margin: 2em auto;
    padding: 1em 2em;
    max-width: 700px;
    -webkit-box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    box-shadow: 0 1px 3px rgba(0, 0, 0, 0.13);
    }
    h1 {
    border-bottom: 1px solid #dadada;
    clear: both;
    color: #666;
    font-size: 24px;
    margin: 30px 0 0 0;
    padding: 0;
    padding-bottom: 7px;
    }
    #error-page {
    margin-top: 50px;
    }
    #error-page p,
    #error-page .wp-die-message {
    font-size: 14px;
    line-height: 1.5;
    margin: 25px 0 20px;
    }
    #error-page code {
    font-family: Consolas, Monaco, monospace;
    }
    ul li {
    margin-bottom: 10px;
    font-size: 14px ;
    }
    a {
    color: #0073aa;
    }
    a:hover,
    a:active {
    color: #00a0d2;
    }
    a:focus {
    color: #124964;
    -webkit-box-shadow:
    0 0 0 1px #5b9dd9,
    0 0 2px 1px rgba(30, 140, 190, 0.8);
    box-shadow:
    0 0 0 1px #5b9dd9,
    0 0 2px 1px rgba(30, 140, 190, 0.8);
    outline: none;
    }
    .button {
    background: #f7f7f7;
    border: 1px solid #ccc;
    color: #555;
    display: inline-block;
    text-decoration: none;
    font-size: 13px;
    line-height: 2;
    height: 28px;
    margin: 0;
    padding: 0 10px 1px;
    cursor: pointer;
    -webkit-border-radius: 3px;
    -webkit-appearance: none;
    border-radius: 3px;
    white-space: nowrap;
    -webkit-box-sizing: border-box;
    -moz-box-sizing: border-box;
    box-sizing: border-box;

    -webkit-box-shadow: 0 1px 0 #ccc;
    box-shadow: 0 1px 0 #ccc;
    vertical-align: top;
    }

    .button.button-large {
    height: 30px;
    line-height: 2.15384615;
    padding: 0 12px 2px;
    }

    .button:hover,
    .button:focus {
    background: #fafafa;
    border-color: #999;
    color: #23282d;
    }

    .button:focus {
    border-color: #5b9dd9;
    -webkit-box-shadow: 0 0 3px rgba(0, 115, 170, 0.8);
    box-shadow: 0 0 3px rgba(0, 115, 170, 0.8);
    outline: none;
    }

    .button:active {
    background: #eee;
    border-color: #999;
    -webkit-box-shadow: inset 0 2px 5px -3px rgba(0, 0, 0, 0.5);
    box-shadow: inset 0 2px 5px -3px rgba(0, 0, 0, 0.5);
    }

    </style>
    </head>
    <body id=”error-page”>
    <div class=”wp-die-message”>Your PHP installation appears to be missing the MySQLi
    extension which is required by WordPress.</div></body>
    </html>

    I have tried may things including running the code from mailpoet-cron.php from a wordpress page where it runs without errors.
    Can you please suggest what may be the problem and how to fix it.
    Thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • It appears that your command-line version of PHP doesn’t have mysqli enabled, preventing WordPress itself from running properly. You could probably replicate this from running php <web document root path>/index.php

    You might want to check your cron/command-line options with your hosting provider.

    Plugin Contributor MailPoet

    (@mailpoet)

    Thanks @deltafactory !

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.