• Resolved Okoth1

    (@okoth1)


    Hello,

    In the previous version of your plugin I didn’t have any problems sending notification mails but in the latest version it’s not sending anything. It’s in the queue but that’s it.

    It also looks like that not all cron jobs are listed in the Cron Info. See here

    Yes, I have read the “How to Schedule Cron Emails” page, but why doesn’t this work out-of-the-box like with other plugins that auto-post?

    I’ve even tried to read the “How to Enable the WordPress Cron” page but that doesn’t make sense to me. There is written:

    “To enable the internal WordPress Cron job system…” define('DISABLE_WP_CRON', true);
    “If you want to enable the WordPress Cron again…” define('DISABLE_WP_CRON', false);

    I’ve tried WP Mail and Php Mail but both of them won’t work.

    ig_es_cron is present in the cron job list but the notification email doesn’t send.

    How can I fix this without setting the cron in CPanel?

    • This topic was modified 2 months, 3 weeks ago by Okoth1.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor kishanranawat

    (@kishanranawat)

    Hi there,

    Along with ‘ig_es_cron‘ cron job, Email Subscribers uses ‘ig_es_cron_worker‘ and ‘ig_es_cron_auto_responder‘ to schedule and send emails. But it looks like these cron jobs are not present on your setup.

    Can you please check your site health report from Tools –> Site Health for any warning related to scheduled events getting missed or loop back requests not enabled?

    Hope this helps you. Let us know if you have any further queries.

    Sorry, I missed this one.

    There are no warnings related to scheduled events.

    Plugin Contributor kishanranawat

    (@kishanranawat)

    Hi there,

    Thanks for giving us more information regarding WP Cron. From the information, we can conclude that the WP cron is working fine.

    Email Subscribers recreates and reschedules the required cron jobs when ‘Disable WordPress Cron‘ is changed.

    Can you try switching ‘Disable WordPress Cron‘ setting from Email Subscribers –> Settings –> Email Sending to on/off and check if it works for you.

    It should create ‘ig_es_cron_worker‘ and ‘ig_es_cron_auto_responder‘ cron jobs along with ‘ig_es_cron‘ when setting is disabled.

    Hope this helps you. Let us know if you have any further queries.

    Okoth1

    (@okoth1)

    This is resolved. After updating to 4.6.0 and removing some code from the theme folder the crons came back and auto-posting became possible again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.