Support » Fixing WordPress » Croissanga no longer synchronizes

  • I’ve used Croissanga for some time to cross-post from my WordPress blog to Xanga and I’ve been very pleased with the plugin. Recently, however, though cross-posting still works, synchronization does not. If I edit or delete the post via WordPress, it just posts a new one on Xanga. I’ve been trying to track down what I’ve changed to cause this, but I’ve had absolutely no luck–I know a few things changed with PHP as I tried to get z00m and phpMyAdmin working properly, but I’ve set everything back to how it was, tried completely getting rid of Croissanga and the MySQL table, and played with various settings all to no avail. Judging by the other Croissanga threads on this forum, I won’t receive a whole lot of help, but I wanted to at least give it a try and see if anyone else had any ideas.

    Plugin: Croissanga (

    WordPress Blog:


    WordPress blog running on: Mandriva 10.1 Official; PHP 5.0.2; Apache 2.0.50; MySQL 4.0.20; WordPress 2.0 (but the problem started happening before I upgraded from 1.5).

    Thanks in advance for all your help. Hopefully I can get this figured out soon.

    PS One last oddity: when I use Performancing ( to post an entry, it posts to Xanga twice (neither of which are editable). This is what leads me to believe that maybe it’s a PHP or XMLRPC issue… but I have absolutely no idea what.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Please try the latest version (1.2.5) with fixes thanks to Ted Pearson.

    I’m stuck with Croissanga too — it quit cross-posting several posts ago (cf. I’ve been using it for quite a while, have kept up with upgrades — now running Croissanga 1.2.7, with WordPress 2.0.2, but crosspostings aren’t making it to Xanga. I looked at the xanga…_map table, and a new row is getting created, but the xanga_id has a number that is the latest Xanga post already there – and not a new Xanga permalink ID.

    I did post directly at Xanga a few times, don’t know if that throws off the cross-posting. I have the right un/pw in the plugin. Anything else I can check?

    Hi, I have the same setup, and it’s not working for me, either. Is there a fix for this? Like DJ, I know I have authenticated properly, but it doesn’t show up. I have the same versions of WordPress and Croissanga at

    I must confess to a large degree of frustration with these threads. A problem is reported, but follow ups never lead to resolution, partly because reporters stop responding. I never know if it’s because the problem went away or they gave up on finding an answer.

    Rant off. You may want to post more info, like what your xanga_* variables are, what other plugins you’ve got activated, whether you can reach from your WP host, if (as djchuang helpfully reported) your database table is getting any updates. Anything at all; I have yet to be able to reproduce a posting problem, so feedback and insights are more than welcome, even if you feel they’re overly verbose.


    No problem. Yeah, I understand. Must be frustrating when people don’t provide enough info.

    In my case, I’m not sure if I have the php curl module installed, as I get the message
    ‘Fatal error: Call to undefined function: curl_init() in /my-website-pathname-here/htdocs/wp-content/plugins/croissanga.php on line 73’. I figure this is because I don’t have the php curl module installed, although I thought with recent versions of php (I have 4.3.10-16), it was installed already, but I don’t see it listed anywhere I run a phpinfo() page. I also don’t have admin access to the box. For the time being, I’ve been using xanga-crossposter, as it doesn’t require php curl. It causes duplicate posts, which is why I’m still sorta looking for one that really works, but it’s acceptable for now…. let me know if you have any suggestions, e.g. whether I do indeed have to get the server admin to recompile php with curl enabled.

    You might try emailing DJ directly to see if he could provide you with the information you listed for his system.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Croissanga no longer synchronizes’ is closed to new replies.