Support » Plugin: Autoptimize » CriticalCSS lowering performance instead of increasing

  • Facing a very peculiar issue since I have started using CriticalCSS which I have tried to debug unsuccessfully. As soon as I delete all the rules and hit the site for the first time, the GTMetrix performance is: Grade A with low blocking time and low content shift.

    But after some time, the GTMetrix performance lowers to Grade B with high blocking time and high content shift. On comparing the html before and after, I could only find this difference:

    <style id="aoatfcss" media="all"> .... </style>

    Also, when I look at criticalcss.com/generate, it always shows that criticalcss is producing different results. Are these two issues related? Can you please give me some pointers as to how I can debug or fix this?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Pragma Apps and Technologies

    (@ipragmatech)

    Hi Frank,

    Could you please take a look at our site and suggest? It looks like the only useful feature that criticalcss does at the moment is defer javascript and conversion of small inline javascript to base64. The css generated by it actually lowers the GTMetrix store and as soon as we delete the automatically generated rule performance is good.

    Can you please help in understanding if we are doing something incorrectly, or it is just an issue with the way the criticalcss auto generation works?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    sorry ipragmatech, had not received a notification of your posts here and see “inline & defer CSS” is off now. I’ll be happy to look into this if ever you want to try again!

    best,
    frank

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘CriticalCSS lowering performance instead of increasing’ is closed to new replies.