Support » Plugin: Woocommerce Minimum and Maximum Quantity » CRITICAL Uncaught DivisionByZeroError

  • Resolved vendelbo

    (@vendelbo)


    Hi – I’m having an issue with all products on a site, where the MinMax feature is not enabled. They cannot be added to cart, and gives: “Critical Error”.

    When I enable and set Min to 1 and Max to 999 it works again.

    I’m running WordPress 5.7.2 and Woocommerce Minimum and Maximum Quantity v 2.1.6

    Your help will be gladly appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Ashok G

    (@wpashokg)

    let me check again.

    2.1.6 broak several ecommerce sites, reverted back to 2.1.5

    I’m having the same issue on all the sites I have this installed on that updated to 2.1.6. I’ve gone ahead and reverted to 2.1.5 to fix the issue for now, but it’s a genuine bug.

    It’s a bug, got the same error on my site.

    Plugin Author Ashok G

    (@wpashokg)

    Hi All,

    I’ve fixed the bug in the new version today. Can you check now. Thanks for all your love and support for this plugin.

    Still having the same critical error with the new version. All plugins and WP core up to date, all plugins turned off but WooCommerce and this one, default theme – still happens. I temporarily re-reverted to the older version.

    Here is the critical error that appears over and over in the WC fatal error status log

    `2021-06-07T15:23:06+00:00 CRITICAL Uncaught DivisionByZeroError: Modulo by zero in /nas/content/live/beenaturals/wp-content/plugins/woo-min-max-quantity-limit/woo-min-max-quantity.php:149
    Stack trace:
    #0 /nas/content/live/beenaturals/wp-includes/class-wp-hook.php(294): wc_mmax_custom_add_to_cart(‘7473c8461a51ce2…’, 102885)
    #1 /nas/content/live/beenaturals/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(”, Array)
    #2 /nas/content/live/beenaturals/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #3 /nas/content/live/beenaturals/wp-content/plugins/woocommerce/includes/class-wc-cart.php(1276): do_action(‘woocommerce_add…’, ‘7473c8461a51ce2…’, 102885, 1, 0, Array, Array)
    #4 /nas/content/live/beenaturals/wp-content/plugins/woocommerce/includes/class-wc-ajax.php(422): WC_Cart->add_to_cart(102885, 1, 0, Array)
    #5 /nas/content/live/beenaturals/wp-includes/class-wp-hook.php(292): WC_AJAX::add_to_cart(”)
    #6 /nas/content/live/beenaturals/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(”, Array)
    #7 /nas/content/live/been in /nas/content/live/beenaturals/wp-content/plugins/woo-min-max-quantity-limit/woo-min-max-quantity.php on line 149

    Plugin Author Ashok G

    (@wpashokg)

    @larosadigital , can you check now. in 2.1.8 I’ve added a fix

    seems to work, thank you! 🙂

    Plugin Author Ashok G

    (@wpashokg)

    @escii thank you for checking it.
    Can you write a review if possible.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.