WordPress.org

Support

Support » Plugins and Hacks » Wordfence Security » [Resolved] Critical Problem with Core File

[Resolved] Critical Problem with Core File

  • Hello, on Friday I installed a plugin called Wordfence Security to help protect my site that I just barely finished building. Upon initial scan Wordfence spotted what it calls a “Critical Problem” with a core WordPress file so I wanted to see if this was something you all think I should ignore or if it really does look like someone has hacked my site.

    Here’s what the error says:
    WordPress core file modified: wp-admin/setup-config.php

    I have a screen shot I can show you of the difference, here’s the
    difference of what Wordfence says it should be and what it is:

    Should be:
    Line 263 if ( ! is_writable(ABSPATH) ) :

    what it is:
    Line 263 if ( ! win_is_writable(ABSPATH) ) :

    http://wordpress.org/plugins/wordfence/

Viewing 9 replies - 1 through 9 (of 9 total)
  • I just got the same thing. Found some other posts on the internet with the same results…but no feedback yet. I spoke with hosting provider and they don’t seem to think it’s a hack.

    Would still like to get some solid feedback on this though….

    Just got it too, but if others are having this issue, I’m thinking that it must be a bug in the app.

    Plugin Author Wordfence

    @mmaunder

    Hi,

    I think you may be running a Windows server. Please note that Wordfence is not officially supported on windows servers at this time.

    However that does look benign so if WF is working for you, you can safely ignore that.

    Regards,

    Mark.

    Just installed today

    I’m hosted on a linux box and I’m getting the same error.

    Original:
    Line 263 if ( ! is_writable(ABSPATH) ) :

    Changed to:
    Line 263 if ( ! win_is_writable(ABSPATH) ) :

    Plugin Author Wordfence

    @mmaunder

    Yup, also probably running Windows.

    Regards,

    Mark.

    Linux

    I’m running Linux, too……but I deleted the warning and experienced no issues after deleting the notice. Nor has the warning reappeared since deleting it.

    Hello,
    I am experiencing the same issue with a new installation. WP version 3.8.1 and WordFence version 4.0.3. Server is Linux. It does seem to be benign, but I would like to understand what is going on. I see this marked RESOLVED, but I guess I missed the resolution part. Thanks, Kris

    I want to register the same issue maybe here is a good place, and suggest this is not a “resolved” topic… I’m getting the same error, and I am very definitely on a LINUX server…

    I’ll add hoping it might be helpful that I have wordfence installed on two sites in the same account on the same shared linux server, both add-on domains, settings all the same, and that this is coming up on one of them and not the other… The one it is coming up on is pretty new, still early in development…

    Some clarity on what is happening would be helpful….

    Regards

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Critical Problem with Core File’ is closed to new replies.
Skip to toolbar